summaryrefslogtreecommitdiff
path: root/examples/analyzer-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/analyzer-plugin/CMakeLists.txt')
-rw-r--r--examples/analyzer-plugin/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/analyzer-plugin/CMakeLists.txt b/examples/analyzer-plugin/CMakeLists.txt
index ba73030cc3..fa8c4fcb32 100644
--- a/examples/analyzer-plugin/CMakeLists.txt
+++ b/examples/analyzer-plugin/CMakeLists.txt
@@ -1,6 +1,8 @@
set(MODULE TRUE)
-set( LLVM_LINK_COMPONENTS support mc)
+set(LLVM_LINK_COMPONENTS
+ Support
+ )
add_clang_library(SampleAnalyzerPlugin MainCallChecker.cpp)
@@ -14,6 +16,8 @@ add_dependencies(SampleAnalyzerPlugin
)
target_link_libraries(SampleAnalyzerPlugin
+ clangAST
+ clangAnalysis
clangStaticAnalyzerCore
)