summaryrefslogtreecommitdiff
path: root/packages/graphics/cairo
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-25 18:43:27 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-25 18:43:27 +0100
commitafc6afe963ea595e94bfc1065a4443dcd5f28020 (patch)
tree7b686e114275640425d7c9708265e4a1b1a18527 /packages/graphics/cairo
parent88967941f8d9b830e672ed3665570c61acf7ab86 (diff)
downloadembtoolkit-afc6afe963ea595e94bfc1065a4443dcd5f28020.tar.gz
embtoolkit-afc6afe963ea595e94bfc1065a4443dcd5f28020.tar.bz2
embtoolkit-afc6afe963ea595e94bfc1065a4443dcd5f28020.tar.xz
Packages: cairo: use directfb
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/graphics/cairo')
-rw-r--r--packages/graphics/cairo/cairo.kconfig1
-rw-r--r--packages/graphics/cairo/cairo.mk4
2 files changed, 3 insertions, 2 deletions
diff --git a/packages/graphics/cairo/cairo.kconfig b/packages/graphics/cairo/cairo.kconfig
index 77c0ab2..de4fec7 100644
--- a/packages/graphics/cairo/cairo.kconfig
+++ b/packages/graphics/cairo/cairo.kconfig
@@ -25,6 +25,7 @@
config EMBTK_HAVE_CAIRO
bool "Have cairo"
select EMBTK_HAVE_PIXMAN
+ select EMBTK_HAVE_DIRECTFB
help
Cairo is a 2D graphics library with support for multiple output
devices. Currently supported output targets include the X Window
diff --git a/packages/graphics/cairo/cairo.mk b/packages/graphics/cairo/cairo.mk
index 49d5af7..5a8f71c 100644
--- a/packages/graphics/cairo/cairo.mk
+++ b/packages/graphics/cairo/cairo.mk
@@ -36,7 +36,7 @@ CAIRO_PKGCONFIGS = cairo*.pc
cairo_install: $(CAIRO_BUILD_DIR)/.installed
$(CAIRO_BUILD_DIR)/.installed: pixman_install libpng_install freetype_install \
- fontconfig_install download_cairo \
+ directfb_install fontconfig_install download_cairo \
$(CAIRO_BUILD_DIR)/.decompressed $(CAIRO_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
cairo-$(CAIRO_VERSION) in your root filesystem...")
@@ -80,7 +80,7 @@ $(CAIRO_BUILD_DIR)/.configured:
PKG_CONFIG_LIBDIR=$(SYSROOT)/usr/lib \
./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
--target=$(STRICT_GNU_TARGET) \
- --prefix=/usr --without-x
+ --prefix=/usr --without-x --enable-directfb
@touch $@
cairo_clean: