summaryrefslogtreecommitdiff
path: root/packages/graphics/directfb
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-10-04 16:57:02 +0200
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-10-04 16:58:59 +0200
commit1674acf74f13f63d8482a4e779c3597aafcb0c03 (patch)
tree11b0789c5e439bca567468c9b8eabcaeeada2191 /packages/graphics/directfb
parentcde61c0ad93adc761351d38d565da2b46a90bc08 (diff)
downloadembtoolkit-1674acf74f13f63d8482a4e779c3597aafcb0c03.tar.gz
embtoolkit-1674acf74f13f63d8482a4e779c3597aafcb0c03.tar.bz2
embtoolkit-1674acf74f13f63d8482a4e779c3597aafcb0c03.tar.xz
Packages: add DirectFB, libpng, libjpeg, pkgconfig
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/graphics/directfb')
-rw-r--r--packages/graphics/directfb/directfb.kconfig53
-rw-r--r--packages/graphics/directfb/directfb.mk74
2 files changed, 127 insertions, 0 deletions
diff --git a/packages/graphics/directfb/directfb.kconfig b/packages/graphics/directfb/directfb.kconfig
new file mode 100644
index 0000000..8a2b7a5
--- /dev/null
+++ b/packages/graphics/directfb/directfb.kconfig
@@ -0,0 +1,53 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file directfb.kconfig
+# \brief directfb.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date October 2009
+################################################################################
+
+config EMBTK_HAVE_DIRECTFB
+ bool "Have DirectFB"
+ select EMBTK_HAVE_LIBPNG
+ select EMBTK_HAVE_LIBJPEG
+ select EMBTK_HAVE_FREETYPE
+ help
+ DirectFB is a graphics library which was designed with embedded
+ systems in mind. It offers maximum hardware accelerated performance
+ at a minimum of resource usage and overhead.
+ Check http://www.directfb.org/ for more and up to date infos.
+
+choice
+ prompt "DirectFB version you wish"
+ default EMBTK_DIRECTFB_VERSION_1_4_2
+ depends on EMBTK_HAVE_DIRECTFB
+ help
+ Here you can choose which version of DirectFB you want to use.
+
+ config EMBTK_DIRECTFB_VERSION_1_4_2
+ bool "DirectFB-1.4.2"
+endchoice
+
+config EMBTK_DIRECTFB_VERSION_STRING
+ string
+ default "1.4.2" if EMBTK_DIRECTFB_VERSION_1_4_2
+config EMBTK_DIRECTFB_BRANCH_STRING
+ string
+ default "DirectFB-1.4" if EMBTK_DIRECTFB_VERSION_1_4_2
+
diff --git a/packages/graphics/directfb/directfb.mk b/packages/graphics/directfb/directfb.mk
new file mode 100644
index 0000000..b92ea83
--- /dev/null
+++ b/packages/graphics/directfb/directfb.mk
@@ -0,0 +1,74 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file directfb.mk
+# \brief directfb.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date October 2009
+################################################################################
+
+DIRECTFB_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_DIRECTFB_VERSION_STRING)))
+DIRECTFB_BRANCH := $(subst ",,$(strip $(CONFIG_EMBTK_DIRECTFB_BRANCH_STRING)))
+DIRECTFB_SITE := http://www.directfb.org/downloads/Core/$(DIRECTFB_BRANCH)
+DIRECTFB_PACKAGE := DirectFB-$(DIRECTFB_VERSION).tar.gz
+DIRECTFB_BUILD_DIR := $(PACKAGES_BUILD)/DirectFB-$(DIRECTFB_VERSION)
+
+directfb_install: $(DIRECTFB_BUILD_DIR)/.installed
+
+$(DIRECTFB_BUILD_DIR)/.installed: libpng_install libjpeg_install \
+ freetype_install download_directfb \
+ $(DIRECTFB_BUILD_DIR)/.decompressed $(DIRECTFB_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ DirectFB-$(DIRECTFB_VERSION) in your root filesystem...")
+ $(Q)cd $(DIRECTFB_BUILD_DIR); $(MAKE) $(J) ; $(MAKE) install
+ $(Q)mkdir -p $(SYSROOT)/usr/lib/pkgconfig
+ $(Q)cp $(ROOTFS)/usr/lib/pkgconfig/* $(SYSROOT)/usr/lib/pkgconfig/
+ $(Q)-cp $(ROOTFS)/usr/lib32/pkgconfig/* $(SYSROOT)/usr/lib32/pkgconfig/
+ $(Q)rm -rf $(ROOTFS)/usr/lib/pkgconfig
+ $(Q)-rm -rf $(ROOTFS)/usr/lib32/pkgconfig
+ @touch $@
+
+download_directfb:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(DIRECTFB_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(DIRECTFB_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(DIRECTFB_PACKAGE) \
+ $(DIRECTFB_SITE)/$(DIRECTFB_PACKAGE)
+
+$(DIRECTFB_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(DIRECTFB_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xzvf $(DOWNLOAD_DIR)/$(DIRECTFB_PACKAGE)
+ @touch $@
+
+$(DIRECTFB_BUILD_DIR)/.configured:
+ cd $(DIRECTFB_BUILD_DIR); \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH="$(SYSROOT)/usr/lib/pkgconfig \
+ $(SYSROOT)/usr/lib32/pkgconfig" \
+ CC=$(TARGETCC_CACHED) CFLAGS=$(TARGET_CFLAGS) \
+ LDFLAGS="-L$(ROOTFS)/usr/lib -L$(ROOTFS)/usr/lib32 \
+ -L$(ROOTFS)/lib -L$(ROOTFS)/lib32 \
+ -L$(SYSROOT)/usr/lib -L$(SYSROOT)/usr/lib32 \
+ -L$(SYSROOT)/lib -L$(SYSROOT)/lib32" \
+ CPPFLAGS="-I$(SYSROOT)/usr/include" \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) --prefix=$(ROOTFS)/usr \
+ --includedir=$(SYSROOT)/usr/include --datarootdir=$(SYSROOT)/usr \
+ --enable-static=no
+ @touch $@
+