summaryrefslogtreecommitdiff
path: root/packages/graphics/freetype/freetype.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-10-04 16:57:02 +0200
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-10-04 16:58:59 +0200
commit1674acf74f13f63d8482a4e779c3597aafcb0c03 (patch)
tree11b0789c5e439bca567468c9b8eabcaeeada2191 /packages/graphics/freetype/freetype.mk
parentcde61c0ad93adc761351d38d565da2b46a90bc08 (diff)
downloadembtoolkit-1674acf74f13f63d8482a4e779c3597aafcb0c03.tar.gz
embtoolkit-1674acf74f13f63d8482a4e779c3597aafcb0c03.tar.bz2
embtoolkit-1674acf74f13f63d8482a4e779c3597aafcb0c03.tar.xz
Packages: add DirectFB, libpng, libjpeg, pkgconfig
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/graphics/freetype/freetype.mk')
-rw-r--r--packages/graphics/freetype/freetype.mk63
1 files changed, 63 insertions, 0 deletions
diff --git a/packages/graphics/freetype/freetype.mk b/packages/graphics/freetype/freetype.mk
new file mode 100644
index 0000000..32e5f53
--- /dev/null
+++ b/packages/graphics/freetype/freetype.mk
@@ -0,0 +1,63 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file freetype.mk
+# \brief freetype.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date October 2009
+################################################################################
+
+FREETYPE_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_FREETYPE_VERSION_STRING)))
+FREETYPE_SITE := http://mirrors.linhub.com/savannah/freetype
+FREETYPE_PACKAGE := freetype-$(FREETYPE_VERSION).tar.bz2
+FREETYPE_BUILD_DIR := $(PACKAGES_BUILD)/freetype-$(FREETYPE_VERSION)
+
+freetype_install: $(FREETYPE_BUILD_DIR)/.installed
+
+$(FREETYPE_BUILD_DIR)/.installed: zlib_target_install download_freetype \
+ $(FREETYPE_BUILD_DIR)/.decompressed $(FREETYPE_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ freetype-$(FREETYPE_VERSION) in your root filesystem...")
+ $(Q)cd $(FREETYPE_BUILD_DIR); $(MAKE) $(J) ; $(MAKE) install
+ $(Q)mkdir -p $(SYSROOT)/usr/lib/pkgconfig
+ $(Q)cp $(ROOTFS)/usr/lib/pkgconfig/* $(SYSROOT)/usr/lib/pkgconfig
+ $(Q)-cp $(ROOTFS)/usr/lib32/pkgconfig/* $(SYSROOT)/usr/lib32/pkgconfig
+ $(Q)rm -rf $(ROOTFS)/usr/lib/pkgconfig
+ $(Q)-rm -rf $(ROOTFS)/usr/lib32/pkgconfig
+ @touch $@
+
+download_freetype:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(FREETYPE_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(FREETYPE_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(FREETYPE_PACKAGE) \
+ $(FREETYPE_SITE)/$(FREETYPE_PACKAGE)
+
+$(FREETYPE_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(FREETYPE_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(FREETYPE_PACKAGE)
+ @touch $@
+
+$(FREETYPE_BUILD_DIR)/.configured:
+ $(Q)cd $(FREETYPE_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) CFLAGS=$(TARGET_CFLAGS) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --prefix=$(ROOTFS)/usr --includedir=$(SYSROOT)/usr/include \
+ --datarootdir=$(SYSROOT)/usr --enable-static=no
+ @touch $@
+