summaryrefslogtreecommitdiff
path: root/packages/graphics/graphics.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-17 23:47:48 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-17 23:54:30 +0100
commit95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220 (patch)
tree8ade3da127195f4ee35f051e286075d78cfe82bc /packages/graphics/graphics.mk
parenta16b2770979813e7f1869dda084a82a131f8c734 (diff)
downloadembtoolkit-95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220.tar.gz
embtoolkit-95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220.tar.bz2
embtoolkit-95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220.tar.xz
Packages: Rework build process and use foo-y targets
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/graphics/graphics.mk')
-rw-r--r--packages/graphics/graphics.mk101
1 files changed, 101 insertions, 0 deletions
diff --git a/packages/graphics/graphics.mk b/packages/graphics/graphics.mk
new file mode 100644
index 0000000..986cf25
--- /dev/null
+++ b/packages/graphics/graphics.mk
@@ -0,0 +1,101 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file graphics.mk
+# \brief graphics.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date February 2010
+################################################################################
+
+#atk
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_ATK) += atk_install
+ROOTFS_COMPONENTS_CLEAN += atk_clean
+ifeq ($(CONFIG_EMBTK_HAVE_ATK),y)
+include $(EMBTK_ROOT)/packages/graphics/atk/atk.mk
+endif
+
+#Cairo
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_CAIRO) += cairo_install
+ROOTFS_COMPONENTS_CLEAN += cairo_clean
+ifeq ($(CONFIG_EMBTK_HAVE_CAIRO),y)
+include $(EMBTK_ROOT)/packages/graphics/cairo/cairo.mk
+endif
+
+#DirectFB
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_DIRECTFB) += directfb_install
+ROOTFS_COMPONENTS_CLEAN += directfb_clean
+ifeq ($(CONFIG_EMBTK_HAVE_DIRECTFB),y)
+include $(EMBTK_ROOT)/packages/graphics/directfb/directfb.mk
+endif
+
+#fontconfig
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FONTCONFIG) += fontconfig_install
+ROOTFS_COMPONENTS_CLEAN += fontconfig_clean
+ifeq ($(CONFIG_EMBTK_HAVE_FONTCONFIG),y)
+include $(EMBTK_ROOT)/packages/graphics/fontconfig/fontconfig.mk
+endif
+
+#FreeFont
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FREEFONT_TTF) += freefont_ttf_install
+ROOTFS_COMPONENTS_CLEAN += ttmkfdir_clean
+ifeq ($(CONFIG_EMBTK_HAVE_FREEFONT_TTF),y)
+include $(EMBTK_ROOT)/packages/graphics/freefont/freefont.mk
+endif
+
+#FreeType
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FREETYPE) += freetype_install
+ROOTFS_COMPONENTS_CLEAN += freetype_clean
+ifeq ($(CONFIG_EMBTK_HAVE_FREETYPE),y)
+include $(EMBTK_ROOT)/packages/graphics/freetype/freetype.mk
+endif
+
+#gtk+
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GTK) += gtk_install
+ROOTFS_COMPONENTS_CLEAN += gtk_clean
+ifeq ($(CONFIG_EMBTK_HAVE_GTK),y)
+include $(EMBTK_ROOT)/packages/graphics/gtk/gtk.mk
+endif
+
+#libjpeg
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBJPEG) += libjpeg_install
+ROOTFS_COMPONENTS_CLEAN += libjpeg_clean
+ifeq ($(CONFIG_EMBTK_HAVE_LIBJPEG),y)
+include $(EMBTK_ROOT)/packages/graphics/libjpeg/libjpeg.mk
+endif
+
+#libpng
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBPNG) += libpng_clean
+ROOTFS_COMPONENTS_CLEAN += libpng_clean
+ifeq ($(CONFIG_EMBTK_HAVE_LIBPNG),y)
+include $(EMBTK_ROOT)/packages/graphics/libpng/libpng.mk
+endif
+
+#libtiff
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBTIFF) += libtiff_install
+ROOTFS_COMPONENTS_CLEAN += libtiff_clean
+ifeq ($(CONFIG_EMBTK_HAVE_LIBTIFF),y)
+include $(EMBTK_ROOT)/packages/graphics/libtiff/libtiff.mk
+endif
+
+#pixman
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_PIXMAN) += pixman_install
+ROOTFS_COMPONENTS_CLEAN += pixman_clean
+ifeq ($(CONFIG_EMBTK_HAVE_PIXMAN),y)
+include $(EMBTK_ROOT)/packages/graphics/pixman/pixman.mk
+endif
+