summaryrefslogtreecommitdiff
path: root/packages/graphics/libtiff
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/graphics/libtiff
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics/libtiff')
-rw-r--r--packages/graphics/libtiff/libtiff.mk25
1 files changed, 9 insertions, 16 deletions
diff --git a/packages/graphics/libtiff/libtiff.mk b/packages/graphics/libtiff/libtiff.mk
index f78b4bc..8939d23 100644
--- a/packages/graphics/libtiff/libtiff.mk
+++ b/packages/graphics/libtiff/libtiff.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2009-2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software; you can distribute it and/or modify it
# under the terms of the GNU General Public License
@@ -18,7 +18,7 @@
#
# \file libtiff.mk
# \brief libtiff.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date December 2009
################################################################################
@@ -36,13 +36,9 @@ LIBTIFF_INCLUDES = tiffconf.h tiff.h tiffio.h tiffio.hxx tiffvers.h
LIBTIFF_LIBS = libtiff*
LIBTIFF_PKGCONFIGS =
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
-else
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
-endif
-
-libtiff_install: $(LIBTIFF_BUILD_DIR)/.installed
+libtiff_install:
+ @test -e $(LIBTIFF_BUILD_DIR)/.installed || \
+ $(MAKE) $(LIBTIFF_BUILD_DIR)/.installed
$(LIBTIFF_BUILD_DIR)/.installed: download_libtiff \
$(LIBTIFF_BUILD_DIR)/.decompressed $(LIBTIFF_BUILD_DIR)/.configured
@@ -91,14 +87,11 @@ $(LIBTIFF_BUILD_DIR)/.configured:
@touch $@
libtiff_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup libtiff-$(LIBTIFF_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup libtiff...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(LIBTIFF_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(LIBTIFF_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBTIFF_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(LIBTIFF_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(LIBTIFF_PKGCONFIGS)
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(LIBTIFF_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(LIBTIFF_PKGCONFIGS)
-endif
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBTIFF_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBTIFF_PKGCONFIGS)
+ $(Q)-rm -rf $(LIBTIFF_BUILD_DIR)