summaryrefslogtreecommitdiff
path: root/packages/graphics
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-25 15:18:57 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-25 15:18:57 +0100
commit2e7b16713a24e10f650b0eb2ae6e7c31cc8c5856 (patch)
tree34ca9d2e5b7e89dcc843ff787e66f79364d0b3ee /packages/graphics
parentbe0b7be2c6b409120793ead4636b2606ece1f51c (diff)
downloadembtoolkit-2e7b16713a24e10f650b0eb2ae6e7c31cc8c5856.tar.gz
embtoolkit-2e7b16713a24e10f650b0eb2ae6e7c31cc8c5856.tar.bz2
embtoolkit-2e7b16713a24e10f650b0eb2ae6e7c31cc8c5856.tar.xz
Packages: New libtiff: add libtiff as buildable package
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/graphics')
-rw-r--r--packages/graphics/libtiff/libtiff.kconfig48
-rw-r--r--packages/graphics/libtiff/libtiff.mk104
2 files changed, 152 insertions, 0 deletions
diff --git a/packages/graphics/libtiff/libtiff.kconfig b/packages/graphics/libtiff/libtiff.kconfig
new file mode 100644
index 0000000..8afe682
--- /dev/null
+++ b/packages/graphics/libtiff/libtiff.kconfig
@@ -0,0 +1,48 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file libtiff.kconfig
+# \brief libtiff.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date December 2009
+################################################################################
+
+config EMBTK_HAVE_LIBTIFF
+ bool "Have libtiff"
+ help
+ libtiff provides support for the Tag Image File Format (TIFF), a
+ widely used format for storing image data.
+ The library, along with associated tool programs, should handle
+ most of your needs for reading and writing TIFF images on 32-
+ and 64-bit machines. This software can also be used on older
+ 16-bit systems though it may require some effort and you may
+ need to leave out some of the compression support.
+choice
+ prompt "libtiff version you wish"
+ depends on EMBTK_HAVE_LIBTIFF
+ help
+ Here you can choose which version of libtiff you want to use.
+
+ config EMBTK_LIBTIFF_VERSION_3_9_2
+ bool "libtiff-3.9.2"
+endchoice
+
+config EMBTK_LIBTIFF_VERSION_STRING
+ string
+ default "3.9.2" if EMBTK_LIBTIFF_VERSION_3_9_2
+
diff --git a/packages/graphics/libtiff/libtiff.mk b/packages/graphics/libtiff/libtiff.mk
new file mode 100644
index 0000000..1fa5441
--- /dev/null
+++ b/packages/graphics/libtiff/libtiff.mk
@@ -0,0 +1,104 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file libtiff.mk
+# \brief libtiff.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date December 2009
+################################################################################
+
+LIBTIFF_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_LIBTIFF_VERSION_STRING)))
+LIBTIFF_SITE := ftp://ftp.remotesensing.org/pub/libtiff
+LIBTIFF_PACKAGE := tiff-$(LIBTIFF_VERSION).tar.gz
+LIBTIFF_BUILD_DIR := $(PACKAGES_BUILD)/tiff-$(LIBTIFF_VERSION)
+
+LIBTIFF_BINS = vbmp2tiff fax2tiff pal2rgb ras2tiff rgb2ycbcr tiff2bw tiff2ps \
+ tiffcmp tiffcrop tiffdump tiffmedian tiffsplit fax2ps gif2tiff \
+ ppm2tiff raw2tiff thumbnail tiff2pdf tiff2rgba tiffcp \
+ tiffdither tiffinfo tiffset
+LIBTIFF_SBINS =
+LIBTIFF_INCLUDES = tiffconf.h tiff.h tiffio.h tiffio.hxx tiffvers.h
+LIBTIFF_LIBS = libtiff*
+LIBTIFF_PKGCONFIGS =
+
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
+else
+PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
+endif
+
+libtiff_install: $(LIBTIFF_BUILD_DIR)/.installed
+
+$(LIBTIFF_BUILD_DIR)/.installed: download_libtiff \
+ $(LIBTIFF_BUILD_DIR)/.decompressed $(LIBTIFF_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ libtiff-$(LIBTIFF_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(LIBTIFF_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(LIBTIFF_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_libtiff:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(LIBTIFF_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(LIBTIFF_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(LIBTIFF_PACKAGE) \
+ $(LIBTIFF_SITE)/$(LIBTIFF_PACKAGE)
+
+$(LIBTIFF_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(LIBTIFF_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xzf $(DOWNLOAD_DIR)/$(LIBTIFF_PACKAGE)
+ @touch $@
+
+$(LIBTIFF_BUILD_DIR)/.configured:
+ $(Q)cd $(LIBTIFF_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/lib -L$(SYSROOT)/usr/lib \
+ -L$(SYSROOT)/lib32 -L$(SYSROOT)/usr/lib32" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) \
+ --prefix=/usr --program-prefix=""
+ @touch $@
+
+libtiff_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup libtiff-$(LIBTIFF_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(LIBTIFF_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(LIBTIFF_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBTIFF_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(LIBTIFF_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(LIBTIFF_PKGCONFIGS)
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+ $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(LIBTIFF_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(LIBTIFF_PKGCONFIGS)
+endif
+