summaryrefslogtreecommitdiff
path: root/packages/graphics
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-24 13:39:35 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-24 13:39:35 +0100
commit5dc62b31653d706327387ca1a1bc3178ffdb122a (patch)
treef403ae6cb49055fa55d54afa3df3efe71042084c /packages/graphics
parent68700ae32bf4c0b720f3dde5fd5f2fe1310137cc (diff)
downloadembtoolkit-5dc62b31653d706327387ca1a1bc3178ffdb122a.tar.gz
embtoolkit-5dc62b31653d706327387ca1a1bc3178ffdb122a.tar.bz2
embtoolkit-5dc62b31653d706327387ca1a1bc3178ffdb122a.tar.xz
packages: freetype: adapt pkgconfig files for cross compile
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/graphics')
-rw-r--r--packages/graphics/freetype/freetype.mk17
1 files changed, 1 insertions, 16 deletions
diff --git a/packages/graphics/freetype/freetype.mk b/packages/graphics/freetype/freetype.mk
index 098c912..1ff619f 100644
--- a/packages/graphics/freetype/freetype.mk
+++ b/packages/graphics/freetype/freetype.mk
@@ -42,7 +42,7 @@ $(FREETYPE_BUILD_DIR)/.installed: zlib_target_install download_freetype \
$(Q)$(MAKE) -C $(FREETYPE_BUILD_DIR) $(J)
$(Q)$(MAKE) -C $(FREETYPE_BUILD_DIR) DESTDIR=$(SYSROOT) install
$(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) $(FREETYPE_BUILD_DIR)/.pkgconfigpatched
+ $(Q)$(MAKE) pkgconfig_files_adapt
$(Q)$(MAKE) $(FREETYPE_BUILD_DIR)/.freetype-configpatched
@touch $@
@@ -73,21 +73,6 @@ $(FREETYPE_BUILD_DIR)/.freetype-configpatched:
> freetype-config.new;\
cp freetype-config.new freetype-config; rm freetype-config.new
-$(FREETYPE_BUILD_DIR)/.pkgconfigpatched:
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)cd $(SYSROOT)/usr/lib32/pkgconfig;\
- cat freetype2.pc | sed -e 's;prefix=/usr;prefix=$(SYSROOT)/usr;' \
- -e 's;includedir=$${prefix}/include;includedir=$(SYSROOT)/usr/include;' \
- > freetype2.pc.new;\
- cp freetype2.pc.new freetype2.pc; rm freetype2.pc.new freetype2.pc.tmp
-else
- $(Q)cd $(SYSROOT)/usr/lib/pkgconfig; \
- cat freetype2.pc | sed -e 's;prefix=/usr;prefix=$(SYSROOT)/usr;' \
- -e 's;includedir=$${prefix}/include;includedir=$(SYSROOT)/usr/include;' \
- > freetype2.pc.new;\
- cp freetype2.pc.new freetype2.pc; rm freetype2.pc.new
-endif
-
freetype_clean:
$(call EMBTK_GENERIC_MESSAGE,"cleanup freetype-$(FREETYPE_VERSION)...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(FREETYPE_BINS)