summaryrefslogtreecommitdiff
path: root/packages/graphics
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-05 16:04:18 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-05 16:04:18 +0200
commitab4aeb680fe66dc0602233c1047d371fe827d70f (patch)
tree0a4e52f81f4e1e3e030e7c3bfda2dd7b3f91b72b /packages/graphics
parentd1bb7e2e60c346398ffc12a630c1278a36bacbb6 (diff)
downloadembtoolkit-ab4aeb680fe66dc0602233c1047d371fe827d70f.tar.gz
embtoolkit-ab4aeb680fe66dc0602233c1047d371fe827d70f.tar.bz2
embtoolkit-ab4aeb680fe66dc0602233c1047d371fe827d70f.tar.xz
Packages: atk: add atk-1.30.0
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics')
-rw-r--r--packages/graphics/atk/atk.kconfig31
-rw-r--r--packages/graphics/atk/atk.mk35
2 files changed, 34 insertions, 32 deletions
diff --git a/packages/graphics/atk/atk.kconfig b/packages/graphics/atk/atk.kconfig
index de35c30..2d62fb1 100644
--- a/packages/graphics/atk/atk.kconfig
+++ b/packages/graphics/atk/atk.kconfig
@@ -1,24 +1,25 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# Copyright(C) 2009-2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file atk.kconfig
# \brief atk.kconfig of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date December 2009
################################################################################
@@ -34,15 +35,19 @@ choice
help
Here you can choose which version of atk you want to use.
+ config EMBTK_ATK_VERSION_1_30_0
+ bool "atk-1.30.0"
config EMBTK_ATK_VERSION_1_28_0
bool "atk-1.28.0"
endchoice
config EMBTK_ATK_MAJOR_VERSION_STRING
string
+ default "1.30" if EMBTK_ATK_VERSION_1_30_0
default "1.28" if EMBTK_ATK_VERSION_1_28_0
config EMBTK_ATK_VERSION_STRING
string
+ default "1.30.0" if EMBTK_ATK_VERSION_1_30_0
default "1.28.0" if EMBTK_ATK_VERSION_1_28_0
diff --git a/packages/graphics/atk/atk.mk b/packages/graphics/atk/atk.mk
index db7ecf8..63f9986 100644
--- a/packages/graphics/atk/atk.mk
+++ b/packages/graphics/atk/atk.mk
@@ -1,24 +1,25 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# Copyright(C) 2009-2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file atk.mk
# \brief atk.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date December 2009
################################################################################
@@ -93,10 +94,6 @@ atk_clean:
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(ATK_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(ATK_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(ATK_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(ATK_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(ATK_PKGCONFIGS)
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(ATK_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(ATK_PKGCONFIGS)
-endif
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(ATK_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(ATK_PKGCONFIGS)