summaryrefslogtreecommitdiff
path: root/packages/graphics
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-07-07 23:39:10 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-07-07 23:39:10 +0200
commitc61a1a262318a0c76ae5a5096427cbc5fd56d196 (patch)
treea5c7df73a7dffb773200e4ad5ae4c27506b79ee8 /packages/graphics
parent40620b287379eecc49a1eee3e5077f916b4cab4c (diff)
downloadembtoolkit-c61a1a262318a0c76ae5a5096427cbc5fd56d196.tar.gz
embtoolkit-c61a1a262318a0c76ae5a5096427cbc5fd56d196.tar.bz2
embtoolkit-c61a1a262318a0c76ae5a5096427cbc5fd56d196.tar.xz
Packages: gtk: Gtk+ only depends on libX11 not xorg-server
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics')
-rw-r--r--packages/graphics/gtk/gtk.kconfig5
-rw-r--r--packages/graphics/gtk/gtk.mk12
2 files changed, 7 insertions, 10 deletions
diff --git a/packages/graphics/gtk/gtk.kconfig b/packages/graphics/gtk/gtk.kconfig
index be9a720..1d1d879 100644
--- a/packages/graphics/gtk/gtk.kconfig
+++ b/packages/graphics/gtk/gtk.kconfig
@@ -1,5 +1,5 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# Copyright(C) 2009-2010 GAYE Abdoulaye Walsimou. All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
@@ -19,7 +19,7 @@
#
# \file gtk.kconfig
# \brief gtk.kconfig of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date December 2009
################################################################################
@@ -53,7 +53,6 @@ choice
select EMBTK_HAVE_CAIRO_WITH_DIRECTFB
config EMBTK_GTK_BACKEND_XSERVER
bool "X windowing system"
- select EMBTK_HAVE_XSERVER
select EMBTK_HAVE_CAIRO_WITH_LIBXCB
select EMBTK_HAVE_LIBX11
select EMBTK_HAVE_LIBXEXT
diff --git a/packages/graphics/gtk/gtk.mk b/packages/graphics/gtk/gtk.mk
index e53b47a..e423078 100644
--- a/packages/graphics/gtk/gtk.mk
+++ b/packages/graphics/gtk/gtk.mk
@@ -1,5 +1,5 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# Copyright(C) 2009-2010 GAYE Abdoulaye Walsimou. All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
@@ -19,7 +19,7 @@
#
# \file gtk.mk
# \brief gtk.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date December 2009
################################################################################
@@ -35,19 +35,17 @@ GTK_INCLUDES = gail-* gtk-*
GTK_LIBS = gtk-* libgail* libgdk-* libgdk_* libgtk-*
GTK_PKGCONFIGS = gail*.pc gdk*.pc gtk*.pc
-GTK_DEPS :=
+GTK_DEPS := libjpeg_install libpng_install libtiff_install fontconfig_install \
+ glib_install atk_install cairo_install pango_install
ifeq ($(CONFIG_EMBTK_GTK_BACKEND_DIRECTFB),y)
GTK_BACKEND := --with-gdktarget=directfb --without-x
GTK_DEPS += directfb_install
else
GTK_BACKEND := --with-gdktarget=x11 --with-x
-GTK_DEPS += xserver_install libxext_install libxrender_install
+GTK_DEPS += libx11_install libxext_install libxrender_install
endif
-GTK_DEPS += libjpeg_install libpng_install libtiff_install fontconfig_install \
- glib_install atk_install cairo_install pango_install
-
gtk_install: $(GTK_BUILD_DIR)/.installed $(GTK_BUILD_DIR)/.special
$(GTK_BUILD_DIR)/.installed: $(GTK_DEPS) download_gtk \