summaryrefslogtreecommitdiff
path: root/packages/graphics
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-13 19:03:04 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-13 19:04:04 +0100
commit5d8187b7d0aee11d13c6194528ae7b9cd4cdcdd5 (patch)
tree2276f81c23e33c19d4376eb818a5adc5f7e9452c /packages/graphics
parent80d6233691bddaecbe9e8b40ecbb4f3559d158c0 (diff)
downloadembtoolkit-5d8187b7d0aee11d13c6194528ae7b9cd4cdcdd5.tar.gz
embtoolkit-5d8187b7d0aee11d13c6194528ae7b9cd4cdcdd5.tar.bz2
embtoolkit-5d8187b7d0aee11d13c6194528ae7b9cd4cdcdd5.tar.xz
Packages: libtiff: Convert to use generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics')
-rw-r--r--packages/graphics/libtiff/libtiff.kconfig32
-rw-r--r--packages/graphics/libtiff/libtiff.mk73
2 files changed, 44 insertions, 61 deletions
diff --git a/packages/graphics/libtiff/libtiff.kconfig b/packages/graphics/libtiff/libtiff.kconfig
index 1f8839f..082cb4f 100644
--- a/packages/graphics/libtiff/libtiff.kconfig
+++ b/packages/graphics/libtiff/libtiff.kconfig
@@ -2,18 +2,19 @@
# Embtoolkit
# Copyright(C) 2009-2011 GAYE Abdoulaye Walsimou. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file libtiff.kconfig
@@ -24,6 +25,7 @@
config EMBTK_HAVE_LIBTIFF
bool "Have libtiff"
+ select EMBTK_LIBTIFF_PKG_IS_TARGZ
help
libtiff provides support for the Tag Image File Format (TIFF), a
widely used format for storing image data.
@@ -36,7 +38,7 @@ choice
prompt "libtiff version you wish"
depends on EMBTK_HAVE_LIBTIFF
help
- Here you can choose which version of libtiff you want to use.
+ Here you can choose which version of libtiff you want to use.
config EMBTK_LIBTIFF_VERSION_3_9_2
bool "libtiff-3.9.2"
@@ -46,3 +48,11 @@ config EMBTK_LIBTIFF_VERSION_STRING
string
default "3.9.2" if EMBTK_LIBTIFF_VERSION_3_9_2
+config EMBTK_LIBTIFF_NEED_PATCH
+ bool
+config EMBTK_LIBTIFF_NEED_AUTORECONF
+ bool
+config EMBTK_LIBTIFF_PKG_IS_TARGZ
+ bool
+config EMBTK_LIBTIFF_PKG_IS_TARBZ2
+ bool
diff --git a/packages/graphics/libtiff/libtiff.mk b/packages/graphics/libtiff/libtiff.mk
index 90e959e..1176018 100644
--- a/packages/graphics/libtiff/libtiff.mk
+++ b/packages/graphics/libtiff/libtiff.mk
@@ -2,18 +2,19 @@
# Embtoolkit
# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file libtiff.mk
@@ -22,9 +23,13 @@
# \date December 2009
################################################################################
-LIBTIFF_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_LIBTIFF_VERSION_STRING)))
+LIBTIFF_NAME := libtiff
+LIBTIFF_VERSION := $(call EMBTK_GET_PKG_VERSION,LIBTIFF)
LIBTIFF_SITE := ftp://ftp.remotesensing.org/pub/libtiff
+LIBTIFF_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+LIBTIFF_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/libtiff/$(LIBTIFF_VERSION)
LIBTIFF_PACKAGE := tiff-$(LIBTIFF_VERSION).tar.gz
+LIBTIFF_SRC_DIR := $(PACKAGES_BUILD)/tiff-$(LIBTIFF_VERSION)
LIBTIFF_BUILD_DIR := $(PACKAGES_BUILD)/tiff-$(LIBTIFF_VERSION)
LIBTIFF_BINS = vbmp2tiff fax2tiff pal2rgb ras2tiff rgb2ycbcr tiff2bw tiff2ps \
@@ -36,6 +41,8 @@ LIBTIFF_INCLUDES = tiffconf.h tiff.h tiffio.h tiffio.hxx tiffvers.h
LIBTIFF_LIBS = libtiff*
LIBTIFF_PKGCONFIGS =
+LIBTIFF_CONFIGURE_OPTS := --disable-cxx --program-prefix=""
+
libtiff_install:
@test -e $(LIBTIFF_BUILD_DIR)/.installed || \
$(MAKE) $(LIBTIFF_BUILD_DIR)/.installed
@@ -44,54 +51,20 @@ $(LIBTIFF_BUILD_DIR)/.installed: download_libtiff \
$(LIBTIFF_BUILD_DIR)/.decompressed $(LIBTIFF_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
libtiff-$(LIBTIFF_VERSION) in your root filesystem...")
- $(call EMBTK_KILL_LT_RPATH, $(LIBTIFF_BUILD_DIR))
$(Q)$(MAKE) -C $(LIBTIFF_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(LIBTIFF_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) -C $(LIBTIFF_BUILD_DIR) DESTDIR=$(SYSROOT)/testlibtiff install
$(Q)$(MAKE) libtool_files_adapt
$(Q)$(MAKE) pkgconfig_files_adapt
@touch $@
download_libtiff:
- $(call EMBTK_GENERIC_MESSAGE,"Downloading $(LIBTIFF_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(LIBTIFF_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(LIBTIFF_PACKAGE) \
- $(LIBTIFF_SITE)/$(LIBTIFF_PACKAGE)
+ $(call EMBTK_DOWNLOAD_PKG,LIBTIFF)
$(LIBTIFF_BUILD_DIR)/.decompressed:
- $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(LIBTIFF_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xzf $(DOWNLOAD_DIR)/$(LIBTIFF_PACKAGE)
- @touch $@
+ $(call EMBTK_DECOMPRESS_PKG,LIBTIFF)
$(LIBTIFF_BUILD_DIR)/.configured:
- $(Q)cd $(LIBTIFF_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLAGS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --disable-cxx \
- --prefix=/usr --program-prefix="" --libdir=/usr/$(LIBDIR)
- @touch $@
+ $(call EMBTK_CONFIGURE_PKG,LIBTIFF)
libtiff_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup libtiff...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(LIBTIFF_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(LIBTIFF_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBTIFF_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBTIFF_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBTIFF_PKGCONFIGS)
- $(Q)-rm -rf $(LIBTIFF_BUILD_DIR)*
-
+ $(call EMBTK_CLEANUP_PKG,LIBTIFF)