summaryrefslogtreecommitdiff
path: root/packages/graphics
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-13 21:30:03 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-13 21:30:03 +0100
commit23b3ba8e76d3456bb6e6198583a4bc0bcf3bbf67 (patch)
treec17c40f0d125d0d765364ddef56b75d82c0e0196 /packages/graphics
parent0139d2b42de33955b602d08b0db47b95d8b54333 (diff)
downloadembtoolkit-23b3ba8e76d3456bb6e6198583a4bc0bcf3bbf67.tar.gz
embtoolkit-23b3ba8e76d3456bb6e6198583a4bc0bcf3bbf67.tar.bz2
embtoolkit-23b3ba8e76d3456bb6e6198583a4bc0bcf3bbf67.tar.xz
Packages: pixman: convert to use generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics')
-rw-r--r--packages/graphics/pixman/pixman.kconfig13
-rw-r--r--packages/graphics/pixman/pixman.mk48
2 files changed, 21 insertions, 40 deletions
diff --git a/packages/graphics/pixman/pixman.kconfig b/packages/graphics/pixman/pixman.kconfig
index 6362d65..a4e2c1e 100644
--- a/packages/graphics/pixman/pixman.kconfig
+++ b/packages/graphics/pixman/pixman.kconfig
@@ -25,8 +25,11 @@
config EMBTK_HAVE_PIXMAN
bool "Have pixman"
+ select EMBTK_PIXMAN_PKG_IS_TARGZ
help
- Pixman
+ pixman is a library that provides low-level pixel manipulation
+ features such as image compositing and trapezoid rasterization.
+
choice
prompt "Pixman version you wish"
depends on EMBTK_HAVE_PIXMAN
@@ -59,3 +62,11 @@ config EMBTK_PIXMAN_VERSION_STRING
default "0.16.5" if EMBTK_PIXMAN_VERSION_0_16_5
default "0.16.4" if EMBTK_PIXMAN_VERSION_0_16_4
+config EMBTK_PIXMAN_NEED_PATCH
+ bool
+config EMBTK_PIXMAN_NEED_AUTORECONF
+ bool
+config EMBTK_PIXMAN_PKG_IS_TARGZ
+ bool
+config EMBTK_PIXMAN_PKG_IS_TARBZ2
+ bool
diff --git a/packages/graphics/pixman/pixman.mk b/packages/graphics/pixman/pixman.mk
index 67153e9..d8676df 100644
--- a/packages/graphics/pixman/pixman.mk
+++ b/packages/graphics/pixman/pixman.mk
@@ -23,9 +23,13 @@
# \date December 2009
################################################################################
-PIXMAN_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_PIXMAN_VERSION_STRING)))
+PIXMAN_NAME := pixman
+PIXMAN_VERSION := $(call EMBTK_GET_PKG_VERSION,PIXMAN)
PIXMAN_SITE := http://www.cairographics.org/releases
+PIXMAN_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+PIXMAN_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/pixman/$(PIXMAN_VERSION)
PIXMAN_PACKAGE := pixman-$(PIXMAN_VERSION).tar.gz
+PIXMAN_SRC_DIR := $(PACKAGES_BUILD)/pixman-$(PIXMAN_VERSION)
PIXMAN_BUILD_DIR := $(PACKAGES_BUILD)/pixman-$(PIXMAN_VERSION)
PIXMAN_BINS =
@@ -42,7 +46,6 @@ $(PIXMAN_BUILD_DIR)/.installed: download_pixman \
$(PIXMAN_BUILD_DIR)/.decompressed $(PIXMAN_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
pixman-$(PIXMAN_VERSION) in your root filesystem...")
- $(call EMBTK_KILL_LT_RPATH, $(PIXMAN_BUILD_DIR))
$(Q)$(MAKE) -C $(PIXMAN_BUILD_DIR) $(J)
$(Q)$(MAKE) -C $(PIXMAN_BUILD_DIR) DESTDIR=$(SYSROOT) install
$(Q)$(MAKE) libtool_files_adapt
@@ -50,46 +53,13 @@ $(PIXMAN_BUILD_DIR)/.installed: download_pixman \
@touch $@
download_pixman:
- $(call EMBTK_GENERIC_MESSAGE,"Downloading $(PIXMAN_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(PIXMAN_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(PIXMAN_PACKAGE) \
- $(PIXMAN_SITE)/$(PIXMAN_PACKAGE)
+ $(call EMBTK_DOWNLOAD_PKG,PIXMAN)
$(PIXMAN_BUILD_DIR)/.decompressed:
- $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(PIXMAN_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xzf $(DOWNLOAD_DIR)/$(PIXMAN_PACKAGE)
- @touch $@
+ $(call EMBTK_DECOMPRESS_PKG,PIXMAN)
$(PIXMAN_BUILD_DIR)/.configured:
- $(Q)cd $(PIXMAN_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLAGS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --libdir=/usr/$(LIBDIR) \
- --prefix=/usr
- @touch $@
+ $(call EMBTK_CONFIGURE_PKG,PIXMAN)
pixman_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup pixman-$(PIXMAN_VERSION)...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(PIXMAN_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(PIXMAN_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(PIXMAN_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(PIXMAN_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(PIXMAN_PKGCONFIGS)
- $(Q)-rm -rf $(PIXMAN_BUILD_DIR)*
-
+ $(call EMBTK_CLEANUP_PKG,PIXMAN)