summaryrefslogtreecommitdiff
path: root/packages/graphics
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-03-11 21:02:09 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-03-11 21:02:09 +0100
commitd9f1f22fae96ecfdd31b3e46ff16ffb79f3fd31e (patch)
tree7f012bfea4c5a6424c0743c581d3c4decff6e977 /packages/graphics
parent2d2beb668e0398bd6e3c0e7160ca352f1c67cec3 (diff)
downloadembtoolkit-d9f1f22fae96ecfdd31b3e46ff16ffb79f3fd31e.tar.gz
embtoolkit-d9f1f22fae96ecfdd31b3e46ff16ffb79f3fd31e.tar.bz2
embtoolkit-d9f1f22fae96ecfdd31b3e46ff16ffb79f3fd31e.tar.xz
Packages: pixman: add pixman-0.20.2
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics')
-rw-r--r--packages/graphics/pixman/pixman.kconfig3
-rw-r--r--packages/graphics/pixman/pixman.mk19
2 files changed, 4 insertions, 18 deletions
diff --git a/packages/graphics/pixman/pixman.kconfig b/packages/graphics/pixman/pixman.kconfig
index a4e2c1e..e9ae07c 100644
--- a/packages/graphics/pixman/pixman.kconfig
+++ b/packages/graphics/pixman/pixman.kconfig
@@ -36,6 +36,8 @@ choice
help
Here you can choose which version of pixman you want to use.
+ config EMBTK_PIXMAN_VERSION_0_20_2
+ bool "pixman-0.20.2"
config EMBTK_PIXMAN_VERSION_0_18_4
bool "pixman-0.18.4"
config EMBTK_PIXMAN_VERSION_0_18_2
@@ -54,6 +56,7 @@ endchoice
config EMBTK_PIXMAN_VERSION_STRING
string
+ default "0.20.2" if EMBTK_PIXMAN_VERSION_0_20_2
default "0.18.4" if EMBTK_PIXMAN_VERSION_0_18_4
default "0.18.2" if EMBTK_PIXMAN_VERSION_0_18_2
default "0.18.1" if EMBTK_PIXMAN_VERSION_0_18_1
diff --git a/packages/graphics/pixman/pixman.mk b/packages/graphics/pixman/pixman.mk
index d8676df..d206ae4 100644
--- a/packages/graphics/pixman/pixman.mk
+++ b/packages/graphics/pixman/pixman.mk
@@ -39,27 +39,10 @@ PIXMAN_LIBS = libpixman-*
PIXMAN_PKGCONFIGS = pixman-*.pc
pixman_install:
- @test -e $(PIXMAN_BUILD_DIR)/.installed || \
- $(MAKE) $(PIXMAN_BUILD_DIR)/.installed
-
-$(PIXMAN_BUILD_DIR)/.installed: download_pixman \
- $(PIXMAN_BUILD_DIR)/.decompressed $(PIXMAN_BUILD_DIR)/.configured
- $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
- pixman-$(PIXMAN_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(PIXMAN_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(PIXMAN_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
+ $(call EMBTK_INSTALL_PKG,PIXMAN)
download_pixman:
$(call EMBTK_DOWNLOAD_PKG,PIXMAN)
-$(PIXMAN_BUILD_DIR)/.decompressed:
- $(call EMBTK_DECOMPRESS_PKG,PIXMAN)
-
-$(PIXMAN_BUILD_DIR)/.configured:
- $(call EMBTK_CONFIGURE_PKG,PIXMAN)
-
pixman_clean:
$(call EMBTK_CLEANUP_PKG,PIXMAN)