summaryrefslogtreecommitdiff
path: root/packages/htools/autoconf/autoconf.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:26:02 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:26:02 +0200
commitc9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd (patch)
treeb76acc217520b55b8f2985749b41ec1afd9396c6 /packages/htools/autoconf/autoconf.mk
parent54c20550455b7ca5808545d476c6927b7f24a3b0 (diff)
downloadembtoolkit-c9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd.tar.gz
embtoolkit-c9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd.tar.bz2
embtoolkit-c9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd.tar.xz
Host tools: move autoconf to htools/autoconf
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools/autoconf/autoconf.mk')
-rw-r--r--packages/htools/autoconf/autoconf.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/htools/autoconf/autoconf.mk b/packages/htools/autoconf/autoconf.mk
new file mode 100644
index 0000000..74b8137
--- /dev/null
+++ b/packages/htools/autoconf/autoconf.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file autoconf.mk
+# \brief autoconf.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+AUTOCONF_HOST_NAME := autoconf
+AUTOCONF_HOST_VERSION := $(call embtk_get_pkgversion,autoconf_host)
+AUTOCONF_HOST_SITE := http://ftp.gnu.org/gnu/autoconf
+AUTOCONF_HOST_PACKAGE := autoconf-$(AUTOCONF_HOST_VERSION).tar.bz2
+AUTOCONF_HOST_SRC_DIR := $(embtk_toolsb)/autoconf-$(AUTOCONF_HOST_VERSION)
+AUTOCONF_HOST_BUILD_DIR := $(embtk_toolsb)/autoconf-$(AUTOCONF_HOST_VERSION)