summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-09-12 00:03:10 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-09-12 00:03:40 +0200
commit06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32 (patch)
tree7264e87fccedfd6dbfeb4671bff60b3d0d842794 /packages/htools
parentb1fb4b94943becfce0d4b7be268295bfffccceea (diff)
downloadembtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.gz
embtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.bz2
embtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.xz
Toolchain: move gmp, mpfr and gmp under host tools
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/gmp/gmp.kconfig36
-rw-r--r--packages/htools/gmp/gmp.mk33
-rw-r--r--packages/htools/hosttools-buildopts.kconfig6
-rw-r--r--packages/htools/hosttools-buildopts.mk15
-rw-r--r--packages/htools/mpc/mpc.kconfig37
-rw-r--r--packages/htools/mpc/mpc.mk37
-rw-r--r--packages/htools/mpfr/mpfr.kconfig37
-rw-r--r--packages/htools/mpfr/mpfr.mk36
8 files changed, 231 insertions, 6 deletions
diff --git a/packages/htools/gmp/gmp.kconfig b/packages/htools/gmp/gmp.kconfig
new file mode 100644
index 0000000..3cb2dd0
--- /dev/null
+++ b/packages/htools/gmp/gmp.kconfig
@@ -0,0 +1,36 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gmp.kconfig
+# \brief gmp.kconfig of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+config EMBTK_HOST_HAVE_GMP
+ bool
+ default y
+
+config EMBTK_GMP_HOST_VERSION_STRING
+ string
+ default "5.0.4"
+
+config EMBTK_GMP_HOST_NEED_PATCH
+ bool
+config EMBTK_GMP_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/gmp/gmp.mk b/packages/htools/gmp/gmp.mk
new file mode 100644
index 0000000..467c6a9
--- /dev/null
+++ b/packages/htools/gmp/gmp.mk
@@ -0,0 +1,33 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gmp.mk
+# \brief gmp.mk of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+
+GMP_HOST_NAME := gmp
+GMP_HOST_VERSION := $(call embtk_get_pkgversion,gmp_host)
+GMP_HOST_SITE := ftp://ftp.gmplib.org/pub/gmp-$(GMP_HOST_VERSION)
+GMP_HOST_PACKAGE := gmp-$(GMP_HOST_VERSION).tar.bz2
+GMP_HOST_SRC_DIR := $(embtk_toolsb)/gmp-$(GMP_HOST_VERSION)
+GMP_HOST_BUILD_DIR := $(embtk_toolsb)/gmp-build
+
+GMP_HOST_CONFIGURE_OPTS := --disable-shared --enable-static
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 482b590..b1d7318 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -82,17 +82,17 @@ source packages/htools/gperf/gperf.kconfig
#
# GMP
#
-source core/kconfig/gmp.kconfig
+source packages/htools/gmp/gmp.kconfig
#
# MPFR
#
-source core/kconfig/mpfr.kconfig
+source packages/htools/mpfr/mpfr.kconfig
#
# MPC
#
-source core/kconfig/mpc.kconfig
+source packages/htools/mpc/mpc.kconfig
#
# ccache
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index c820883..3ff097b 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -41,6 +41,12 @@ $(call embtk_include_hostpkg,fakeroot_host)
# gmake
$(call embtk_include_hostpkg,gmake_host)
+# gmp
+$(call embtk_include_hostpkg,gmp_host)
+
+# gperf
+$(call embtk_include_hostpkg,gperf_host)
+
# gsed
$(call embtk_include_hostpkg,gsed_host)
@@ -50,6 +56,12 @@ $(call embtk_include_hostpkg,libelf_host)
# libtool
$(call embtk_include_hostpkg,libtool_host)
+# mpc
+$(call embtk_include_hostpkg,mpc_host)
+
+# mpfr
+$(call embtk_include_hostpkg,mpfr_host)
+
# mtd-utils
$(call embtk_include_hostpkg,mtdutils_host)
@@ -65,6 +77,3 @@ $(call embtk_include_hostpkg,squashfs_host)
# zlib
$(call embtk_include_hostpkg,zlib_host)
-
-# gperf
-$(call embtk_include_hostpkg,gperf_host)
diff --git a/packages/htools/mpc/mpc.kconfig b/packages/htools/mpc/mpc.kconfig
new file mode 100644
index 0000000..3b5ece8
--- /dev/null
+++ b/packages/htools/mpc/mpc.kconfig
@@ -0,0 +1,37 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file mpc.kconfig
+# \brief mpc.kconfig of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date Jan 2010
+################################################################################
+
+config EMBTK_HOST_HAVE_MPC
+ bool
+ default y
+
+config EMBTK_MPC_HOST_VERSION_STRING
+ string
+ default "0.8.2"
+
+config EMBTK_MPC_HOST_NEED_PATCH
+ bool
+config EMBTK_MPC_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/mpc/mpc.mk b/packages/htools/mpc/mpc.mk
new file mode 100644
index 0000000..acea500
--- /dev/null
+++ b/packages/htools/mpc/mpc.mk
@@ -0,0 +1,37 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file mpc.mk
+# \brief mpch.mk of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date Jan 2010
+################################################################################
+
+MPC_HOST_NAME := mpc
+MPC_HOST_VERSION := $(call embtk_get_pkgversion,mpc_host)
+MPC_HOST_SITE := http://www.multiprecision.org/mpc/download
+MPC_HOST_PACKAGE := mpc-$(MPC_HOST_VERSION).tar.gz
+MPC_HOST_SRC_DIR := $(embtk_toolsb)/mpc-$(MPC_HOST_VERSION)
+MPC_HOST_BUILD_DIR := $(embtk_toolsb)/mpc-$(MPC_HOST_VERSION)-build
+
+MPC_HOST_DEPS := gmp_host_install mpfr_host_install
+
+MPC_HOST_CONFIGURE_OPTS := --disable-shared --enable-static
+MPC_HOST_CONFIGURE_OPTS += --with-gmp=$(embtk_htools)
+MPC_HOST_CONFIGURE_OPTS += --with-mpfr=$(embtk_htools)
diff --git a/packages/htools/mpfr/mpfr.kconfig b/packages/htools/mpfr/mpfr.kconfig
new file mode 100644
index 0000000..a944cf8
--- /dev/null
+++ b/packages/htools/mpfr/mpfr.kconfig
@@ -0,0 +1,37 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file mpfr.kconfig
+# \brief mpfr.kconfig of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+
+config EMBTK_HOST_HAVE_MPFR
+ bool
+ default y
+
+config EMBTK_MPFR_HOST_VERSION_STRING
+ string
+ default "2.4.2"
+
+config EMBTK_MPFR_HOST_NEED_PATCH
+ bool
+config EMBTK_MPFR_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/mpfr/mpfr.mk b/packages/htools/mpfr/mpfr.mk
new file mode 100644
index 0000000..87a7f74
--- /dev/null
+++ b/packages/htools/mpfr/mpfr.mk
@@ -0,0 +1,36 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file mpfr.mk
+# \brief mpfr.mk of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+
+MPFR_HOST_NAME := mpfr
+MPFR_HOST_VERSION := $(call embtk_get_pkgversion,mpfr_host)
+MPFR_HOST_SITE := http://www.mpfr.org/mpfr-$(MPFR_HOST_VERSION)
+MPFR_HOST_PACKAGE := mpfr-$(MPFR_HOST_VERSION).tar.bz2
+MPFR_HOST_SRC_DIR := $(embtk_toolsb)/mpfr-$(MPFR_HOST_VERSION)
+MPFR_HOST_BUILD_DIR := $(embtk_toolsb)/mpfr-$(MPFR_HOST_VERSION)-build
+
+MPFR_HOST_DEPS := gmp_host_install
+
+MPFR_HOST_CONFIGURE_OPTS := --disable-shared --enable-static
+MPFR_HOST_CONFIGURE_OPTS += --with-gmp=$(embtk_htools)