summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-03-25 20:47:09 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-03-25 20:51:35 +0100
commit1c184aff456c29c1cc6b97c9b089da7d0898e632 (patch)
tree7d40d86753c4db3cf8cce7dea64fc7b873e58f38 /packages/htools
parent59c92e851303bec7834d33ee1fbef321a32abbc9 (diff)
downloadembtoolkit-1c184aff456c29c1cc6b97c9b089da7d0898e632.tar.gz
embtoolkit-1c184aff456c29c1cc6b97c9b089da7d0898e632.tar.bz2
embtoolkit-1c184aff456c29c1cc6b97c9b089da7d0898e632.tar.xz
Host tools: move gperf to packages/htools/
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/gperf/gperf.kconfig43
-rw-r--r--packages/htools/gperf/gperf.mk31
-rw-r--r--packages/htools/hosttools-buildopts.kconfig7
-rw-r--r--packages/htools/hosttools-buildopts.mk3
4 files changed, 78 insertions, 6 deletions
diff --git a/packages/htools/gperf/gperf.kconfig b/packages/htools/gperf/gperf.kconfig
new file mode 100644
index 0000000..7be2403
--- /dev/null
+++ b/packages/htools/gperf/gperf.kconfig
@@ -0,0 +1,43 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gperf_host.kconfig
+# \brief gperf_host.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_GPERF
+ bool
+ help
+ This is GNU gperf. It is a program that generates perfect hash
+ functions for sets of key words.
+ A perfect hash function is:
+ A hash function and a data structure that allows recognition of a key
+ word in a set of words using exactly 1 probe into the data structure.
+
+if EMBTK_HOST_HAVE_GPERF
+config EMBTK_GPERF_HOST_VERSION_STRING
+ string
+ default "3.0.4"
+config EMBTK_GPERF_HOST_NEED_PATCH
+ bool
+config EMBTK_GPERF_HOST_NEED_AUTORECONF
+ bool
+endif
diff --git a/packages/htools/gperf/gperf.mk b/packages/htools/gperf/gperf.mk
new file mode 100644
index 0000000..42b696b
--- /dev/null
+++ b/packages/htools/gperf/gperf.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gperf_host.mk
+# \brief gperf_host.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2011
+################################################################################
+
+GPERF_HOST_NAME := gperf
+GPERF_HOST_VERSION := $(call embtk_get_pkgversion,gperf_host)
+GPERF_HOST_SITE := http://ftp.gnu.org/gnu/gperf
+GPERF_HOST_PACKAGE := gperf-$(GPERF_HOST_VERSION).tar.gz
+GPERF_HOST_SRC_DIR := $(embtk_toolsb)/gperf-$(GPERF_HOST_VERSION)
+GPERF_HOST_BUILD_DIR := $(embtk_toolsb)/gperf-$(GPERF_HOST_VERSION)-build
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 1c1a874..5dac98a 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -77,7 +77,7 @@ config EMBTK_HAVE_MKIMAGE
#
# gperf for host
#
-source core/kconfig/gperf_host.kconfig
+source packages/htools/gperf/gperf.kconfig
#
# GMP
@@ -138,11 +138,6 @@ source packages/htools/pkgconf/pkgconf.kconfig
source packages/htools/fakeroot/fakeroot.kconfig
#
-# gperf for host
-#
-source core/kconfig/gperf_host.kconfig
-
-#
# libelf
#
source packages/misc/libelf/libelf.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index cde4230..cb66b4c 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -44,3 +44,6 @@ $(call embtk_include_hostpkg,squashfs_host)
# zlib
$(call embtk_include_hostpkg,zlib_host)
+
+# gperf
+$(call embtk_include_hostpkg,gperf_host)