summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-03-16 16:00:34 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-03-16 16:03:46 +0100
commit382870266c468a8abbe87cc3e96d07292abac64f (patch)
tree79436f9b9727178a6d816369bf91b5d0972a19c0 /packages/htools
parent76d0e62a677a2ba4823ddc82ff884ed58f0588c0 (diff)
downloadembtoolkit-382870266c468a8abbe87cc3e96d07292abac64f.tar.gz
embtoolkit-382870266c468a8abbe87cc3e96d07292abac64f.tar.bz2
embtoolkit-382870266c468a8abbe87cc3e96d07292abac64f.tar.xz
build system: move fakeroot under packages/htools/
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/fakeroot/fakeroot.kconfig39
-rw-r--r--packages/htools/fakeroot/fakeroot.mk32
-rw-r--r--packages/htools/fakeroot/vars.mk29
-rw-r--r--packages/htools/hosttools-buildopts.kconfig2
-rw-r--r--packages/htools/hosttools-buildopts.mk4
5 files changed, 105 insertions, 1 deletions
diff --git a/packages/htools/fakeroot/fakeroot.kconfig b/packages/htools/fakeroot/fakeroot.kconfig
new file mode 100644
index 0000000..81eec51
--- /dev/null
+++ b/packages/htools/fakeroot/fakeroot.kconfig
@@ -0,0 +1,39 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011-2013 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file fakeroot.kconfig
+# \brief fakeroot.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date March 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_FAKEROOT
+ bool
+ default y
+ help
+ fakeroot for host tools.
+
+config EMBTK_FAKEROOT_HOST_VERSION_STRING
+ string
+ default "1.18.4"
+
+config EMBTK_FAKEROOT_HOST_NEED_PATCH
+ bool
+config EMBTK_FAKEROOT_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/fakeroot/fakeroot.mk b/packages/htools/fakeroot/fakeroot.mk
new file mode 100644
index 0000000..dc9f357
--- /dev/null
+++ b/packages/htools/fakeroot/fakeroot.mk
@@ -0,0 +1,32 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file fakeroot.mk
+# \brief fakeroot.mk of Embtoolkit. fakeroot helps building root
+# \brief filesystem, without the need to be root.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2009
+################################################################################
+
+FAKEROOT_HOST_NAME := fakeroot
+FAKEROOT_HOST_VERSION := $(call embtk_get_pkgversion,fakeroot_host)
+FAKEROOT_HOST_SITE := http://ftp.debian.org/debian/pool/main/f/fakeroot
+FAKEROOT_HOST_PACKAGE := fakeroot_$(FAKEROOT_HOST_VERSION).orig.tar.bz2
+FAKEROOT_HOST_SRC_DIR := $(embtk_toolsb)/fakeroot-$(FAKEROOT_HOST_VERSION)
+FAKEROOT_HOST_BUILD_DIR := $(embtk_toolsb)/fakeroot-build
diff --git a/packages/htools/fakeroot/vars.mk b/packages/htools/fakeroot/vars.mk
new file mode 100644
index 0000000..252a0cc
--- /dev/null
+++ b/packages/htools/fakeroot/vars.mk
@@ -0,0 +1,29 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file vars.mk
+# \brief fakeroot variables
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date Marsh 2014
+################################################################################
+
+# fakeroot binaries and env
+FAKEROOT_BIN := $(embtk_htools)/usr/bin/fakeroot
+FAKEROOT_ENV_FILE := $(EMBTK_ROOT)/.fakeroot.001
+export FAKEROOT_BIN FAKEROOT_ENV_FILE
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 07c8b6a..b502753 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -135,7 +135,7 @@ source kconfig/pkgconf.kconfig
#
# fakeroot
#
-source kconfig/fakeroot.kconfig
+source packages/htools/fakeroot/fakeroot.kconfig
#
# gperf for host
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index b4dd8b1..8785184 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -27,3 +27,7 @@ embtk_pkgincdir := packages/htools
# cache
$(call embtk_include_hostpkg,ccache_host)
+
+# fakeroot
+include packages/htools/fakeroot/vars.mk
+$(call embtk_include_hostpkg,fakeroot_host)