summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:13:43 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:14:31 +0200
commit54c20550455b7ca5808545d476c6927b7f24a3b0 (patch)
tree87a51ef88f014692580dae37d83540c8e24bed62 /packages/htools
parentf5286d55871178d127a030023f6960aefc502d71 (diff)
downloadembtoolkit-54c20550455b7ca5808545d476c6927b7f24a3b0.tar.gz
embtoolkit-54c20550455b7ca5808545d476c6927b7f24a3b0.tar.bz2
embtoolkit-54c20550455b7ca5808545d476c6927b7f24a3b0.tar.xz
Host tools: move libtool to htools/libtool
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/hosttools-buildopts.kconfig2
-rw-r--r--packages/htools/hosttools-buildopts.mk3
-rw-r--r--packages/htools/libtool/libtool.kconfig39
-rw-r--r--packages/htools/libtool/libtool.mk31
-rw-r--r--packages/htools/libtool/vars.mk28
5 files changed, 102 insertions, 1 deletions
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 4541439..1abbf89 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -103,7 +103,7 @@ source packages/htools/ccache/ccache.kconfig
# Autotools
#
source packages/htools/m4/m4.kconfig
-source core/kconfig/libtool.kconfig
+source packages/htools/libtool/libtool.kconfig
source core/kconfig/autoconf.kconfig
source core/kconfig/automake.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index c7be0ad..5436f6e 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -32,6 +32,9 @@ $(call embtk_include_hostpkg,ccache_host)
include packages/htools/fakeroot/vars.mk
$(call embtk_include_hostpkg,fakeroot_host)
+# libtool
+$(call embtk_include_hostpkg,libtool_host)
+
# mtd-utils
$(call embtk_include_hostpkg,mtdutils_host)
diff --git a/packages/htools/libtool/libtool.kconfig b/packages/htools/libtool/libtool.kconfig
new file mode 100644
index 0000000..e222418
--- /dev/null
+++ b/packages/htools/libtool/libtool.kconfig
@@ -0,0 +1,39 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libtool.kconfig
+# \brief libtool.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_LIBTOOL
+ bool
+ default y
+ help
+ libtool for autotools.
+
+config EMBTK_LIBTOOL_HOST_VERSION_STRING
+ string
+ default "2.4.2"
+
+config EMBTK_LIBTOOL_HOST_NEED_PATCH
+ bool
+config EMBTK_LIBTOOL_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/libtool/libtool.mk b/packages/htools/libtool/libtool.mk
new file mode 100644
index 0000000..6900afd
--- /dev/null
+++ b/packages/htools/libtool/libtool.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libtool.mk
+# \brief libtool.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date March 2010
+################################################################################
+
+LIBTOOL_HOST_NAME := libtool
+LIBTOOL_HOST_VERSION := $(call embtk_get_pkgversion,libtool_host)
+LIBTOOL_HOST_SITE := http://ftp.gnu.org/gnu/libtool
+LIBTOOL_HOST_PACKAGE := libtool-$(LIBTOOL_HOST_VERSION).tar.gz
+LIBTOOL_HOST_SRC_DIR := $(embtk_toolsb)/libtool-$(LIBTOOL_HOST_VERSION)
+LIBTOOL_HOST_BUILD_DIR := $(embtk_toolsb)/libtool-$(LIBTOOL_HOST_VERSION)
diff --git a/packages/htools/libtool/vars.mk b/packages/htools/libtool/vars.mk
new file mode 100644
index 0000000..71c8816
--- /dev/null
+++ b/packages/htools/libtool/vars.mk
@@ -0,0 +1,28 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libtool.mk
+# \brief libtool.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date March 2010
+################################################################################
+
+LIBTOOL := $(embtk_htools)/usr/bin/libtool
+LIBTOOLIZE := $(embtk_htools)/usr/bin/libtoolize
+export LIBTOOL LIBTOOLIZE