summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:35:43 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:36:46 +0200
commit795308c52496f172ca1f354a49a9def48a2d1712 (patch)
tree50ccbe91a1ac1f591b93308d117d307160078f5b /packages/htools
parentc9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd (diff)
downloadembtoolkit-795308c52496f172ca1f354a49a9def48a2d1712.tar.gz
embtoolkit-795308c52496f172ca1f354a49a9def48a2d1712.tar.bz2
embtoolkit-795308c52496f172ca1f354a49a9def48a2d1712.tar.xz
Host tools: move autoconf to htools/automake
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/automake/automake.kconfig39
-rw-r--r--packages/htools/automake/automake.mk31
-rw-r--r--packages/htools/automake/vars.mk29
-rw-r--r--packages/htools/hosttools-buildopts.kconfig2
-rw-r--r--packages/htools/hosttools-buildopts.mk3
5 files changed, 103 insertions, 1 deletions
diff --git a/packages/htools/automake/automake.kconfig b/packages/htools/automake/automake.kconfig
new file mode 100644
index 0000000..ba2ef10
--- /dev/null
+++ b/packages/htools/automake/automake.kconfig
@@ -0,0 +1,39 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file automake.kconfig
+# \brief automake.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_AUTOMAKE
+ bool
+ default y
+ help
+ automake for autotools.
+
+config EMBTK_AUTOMAKE_HOST_VERSION_STRING
+ string
+ default "1.11.6"
+
+config EMBTK_AUTOMAKE_HOST_NEED_PATCH
+ bool
+config EMBTK_AUTOMAKE_HOS_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/automake/automake.mk b/packages/htools/automake/automake.mk
new file mode 100644
index 0000000..7367832
--- /dev/null
+++ b/packages/htools/automake/automake.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file automake.mk
+# \brief automake.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+AUTOMAKE_HOST_NAME := automake
+AUTOMAKE_HOST_VERSION := $(call embtk_get_pkgversion,automake_host)
+AUTOMAKE_HOST_SITE := http://ftp.gnu.org/gnu/automake
+AUTOMAKE_HOST_PACKAGE := automake-$(AUTOMAKE_HOST_VERSION).tar.xz
+AUTOMAKE_HOST_SRC_DIR := $(embtk_toolsb)/automake-$(AUTOMAKE_HOST_VERSION)
+AUTOMAKE_HOST_BUILD_DIR := $(embtk_toolsb)/automake-$(AUTOMAKE_HOST_VERSION)
diff --git a/packages/htools/automake/vars.mk b/packages/htools/automake/vars.mk
new file mode 100644
index 0000000..82285bc
--- /dev/null
+++ b/packages/htools/automake/vars.mk
@@ -0,0 +1,29 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file automake.mk
+# \brief automake.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+AUTOMAKE_DIR := $(embtk_htools)/usr
+ACLOCAL := $(AUTOMAKE_DIR)/bin/aclocal
+AUTOMAKE := $(AUTOMAKE_DIR)/bin/automake
+export ACLOCAL AUTOMAKE
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 36aa44d..48a6fd8 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -105,7 +105,7 @@ source packages/htools/ccache/ccache.kconfig
source packages/htools/m4/m4.kconfig
source packages/htools/libtool/libtool.kconfig
source packages/htools/autoconf/autoconf.kconfig
-source core/kconfig/automake.kconfig
+source packages/htools/automake/automake.kconfig
#
# GNU sed
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index 0d640b1..b163a9a 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -28,6 +28,9 @@ embtk_pkgincdir := packages/htools
# autoconf
$(call embtk_include_hostpkg,autoconf_host)
+# automake
+$(call embtk_include_hostpkg,automake_host)
+
# cache
$(call embtk_include_hostpkg,ccache_host)