summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-31 23:47:13 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-31 23:47:13 +0100
commit825e95335d51b22462960da654275c9377068aed (patch)
tree9c7999c67b620c0607750538a8060ae1ff1d385e /packages/htools
parent934c86cca457c939b69e2724ee97073f8c7486f6 (diff)
downloadembtoolkit-825e95335d51b22462960da654275c9377068aed.tar.gz
embtoolkit-825e95335d51b22462960da654275c9377068aed.tar.bz2
embtoolkit-825e95335d51b22462960da654275c9377068aed.tar.xz
Host tools: add findutils
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/findutils/findutils.kconfig39
-rw-r--r--packages/htools/findutils/findutils.mk33
-rw-r--r--packages/htools/hosttools-buildopts.kconfig5
-rw-r--r--packages/htools/hosttools-buildopts.mk3
4 files changed, 80 insertions, 0 deletions
diff --git a/packages/htools/findutils/findutils.kconfig b/packages/htools/findutils/findutils.kconfig
new file mode 100644
index 0000000..591ff88
--- /dev/null
+++ b/packages/htools/findutils/findutils.kconfig
@@ -0,0 +1,39 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file findutils.kconfig
+# \brief findutils for host development machine
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date October 2014
+################################################################################
+
+config EMBTK_HOST_HAVE_FINDUTILS
+ bool
+ default y if EMBTK_HOST_OS=macos
+ help
+ findutils for host development machine
+
+config EMBTK_FINDUTILS_HOST_VERSION_STRING
+ string
+ default "4.4.2"
+
+config EMBTK_FINDUTILS_HOST_NEED_PATCH
+ bool
+config EMBTK_FINDUTILS_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/findutils/findutils.mk b/packages/htools/findutils/findutils.mk
new file mode 100644
index 0000000..70c8a96
--- /dev/null
+++ b/packages/htools/findutils/findutils.mk
@@ -0,0 +1,33 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file findutils.mk
+# \brief findutils for host development machine
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date October 2014
+################################################################################
+
+FINDUTILS_HOST_NAME := findutils
+FINDUTILS_HOST_VERSION := $(call embtk_get_pkgversion,findutils_host)
+FINDUTILS_HOST_SITE := http://ftp.gnu.org/pub/gnu/findutils
+FINDUTILS_HOST_PACKAGE := findutils-$(FINDUTILS_HOST_VERSION).tar.gz
+FINDUTILS_HOST_SRC_DIR := $(embtk_toolsb)/findutils-$(FINDUTILS_HOST_VERSION)
+FINDUTILS_HOST_BUILD_DIR := $(embtk_toolsb)/findutils-$(FINDUTILS_HOST_VERSION)-build
+
+FINDUTILS_HOST_CONFIGURE_OPTS := --disable-nls
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index cffaeeb..6dd450c 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -148,6 +148,11 @@ source packages/htools/pkgconf/pkgconf.kconfig
source packages/htools/fakeroot/fakeroot.kconfig
#
+# findutils
+#
+source packages/htools/findutils/findutils.kconfig
+
+#
# libelf
#
source packages/htools/libelf/libelf.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index ae99d5f..8e26f71 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -38,6 +38,9 @@ $(call embtk_include_hostpkg,ccache_host)
include packages/htools/fakeroot/vars.mk
$(call embtk_include_hostpkg,fakeroot_host)
+# findutils
+$(call embtk_include_hostpkg,findutils_host)
+
# gettext
$(call embtk_include_hostpkg,gettext_host)