summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:26:02 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:26:02 +0200
commitc9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd (patch)
treeb76acc217520b55b8f2985749b41ec1afd9396c6 /packages/htools
parent54c20550455b7ca5808545d476c6927b7f24a3b0 (diff)
downloadembtoolkit-c9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd.tar.gz
embtoolkit-c9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd.tar.bz2
embtoolkit-c9f15211a7fb93d3e78c7dc9ba4500aa1ca3b5cd.tar.xz
Host tools: move autoconf to htools/autoconf
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/autoconf/autoconf.kconfig38
-rw-r--r--packages/htools/autoconf/autoconf.mk31
-rw-r--r--packages/htools/autoconf/vars.mk36
-rw-r--r--packages/htools/hosttools-buildopts.kconfig2
-rw-r--r--packages/htools/hosttools-buildopts.mk3
5 files changed, 109 insertions, 1 deletions
diff --git a/packages/htools/autoconf/autoconf.kconfig b/packages/htools/autoconf/autoconf.kconfig
new file mode 100644
index 0000000..a92d615
--- /dev/null
+++ b/packages/htools/autoconf/autoconf.kconfig
@@ -0,0 +1,38 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file autoconf.kconfig
+# \brief autoconf.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2011
+################################################################################
+
+
+#
+# Default autoconf version
+#
+config EMBTK_HOST_HAVE_AUTOCONF
+ bool
+ default y
+ help
+ autoconf for autotools.
+
+config EMBTK_AUTOCONF_HOST_VERSION_STRING
+ string
+ default "2.68"
diff --git a/packages/htools/autoconf/autoconf.mk b/packages/htools/autoconf/autoconf.mk
new file mode 100644
index 0000000..74b8137
--- /dev/null
+++ b/packages/htools/autoconf/autoconf.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file autoconf.mk
+# \brief autoconf.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+AUTOCONF_HOST_NAME := autoconf
+AUTOCONF_HOST_VERSION := $(call embtk_get_pkgversion,autoconf_host)
+AUTOCONF_HOST_SITE := http://ftp.gnu.org/gnu/autoconf
+AUTOCONF_HOST_PACKAGE := autoconf-$(AUTOCONF_HOST_VERSION).tar.bz2
+AUTOCONF_HOST_SRC_DIR := $(embtk_toolsb)/autoconf-$(AUTOCONF_HOST_VERSION)
+AUTOCONF_HOST_BUILD_DIR := $(embtk_toolsb)/autoconf-$(AUTOCONF_HOST_VERSION)
diff --git a/packages/htools/autoconf/vars.mk b/packages/htools/autoconf/vars.mk
new file mode 100644
index 0000000..765f946
--- /dev/null
+++ b/packages/htools/autoconf/vars.mk
@@ -0,0 +1,36 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file autoconf.mk
+# \brief autoconf.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+# autoconf binaries
+AUTOCONF_DIR := $(embtk_htools)/usr
+AUTOCONF := $(AUTOCONF_DIR)/bin/autoconf
+AUTOHEADER := $(AUTOCONF_DIR)/bin/autoheader
+AUTOM4TE := $(AUTOCONF_DIR)/bin/autom4te
+AUTORECONF := $(AUTOCONF_DIR)/bin/autoreconf
+AUTOSCAN := $(AUTOCONF_DIR)/bin/autoscan
+AUTOUPDATE := $(AUTOCONF_DIR)/bin/autoupdate
+IFNAMES := $(AUTOCONF_DIR)/bin/ifnames
+
+export AUTOCONF AUTOHEADER AUTOM4TE AUTORECONF AUTOSCAN AUTOUPDATE IFNAMES
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 1abbf89..36aa44d 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -104,7 +104,7 @@ source packages/htools/ccache/ccache.kconfig
#
source packages/htools/m4/m4.kconfig
source packages/htools/libtool/libtool.kconfig
-source core/kconfig/autoconf.kconfig
+source packages/htools/autoconf/autoconf.kconfig
source core/kconfig/automake.kconfig
#
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index 5436f6e..0d640b1 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -25,6 +25,9 @@
embtk_pkgincdir := packages/htools
+# autoconf
+$(call embtk_include_hostpkg,autoconf_host)
+
# cache
$(call embtk_include_hostpkg,ccache_host)