summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-10 15:02:18 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-10 17:07:44 +0200
commitdc75991cc4c23d2675aa357692ed26d7d21e569c (patch)
treee7b3a13c6b98ce15ba2aac9b3147beb7cc4d5350 /packages/htools
parent506b8e57f3e7675b4ad6a0006c61fd0094038bb4 (diff)
downloadembtoolkit-dc75991cc4c23d2675aa357692ed26d7d21e569c.tar.gz
embtoolkit-dc75991cc4c23d2675aa357692ed26d7d21e569c.tar.bz2
embtoolkit-dc75991cc4c23d2675aa357692ed26d7d21e569c.tar.xz
Host tools: add waf in order to build waf base packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/hosttools-buildopts.kconfig5
-rw-r--r--packages/htools/hosttools-buildopts.mk4
-rw-r--r--packages/htools/waf/vars.mk1
-rw-r--r--packages/htools/waf/waf.kconfig31
-rw-r--r--packages/htools/waf/waf.mk48
5 files changed, 89 insertions, 0 deletions
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 5dac98a..55194b5 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -143,6 +143,11 @@ source packages/htools/fakeroot/fakeroot.kconfig
source packages/misc/libelf/libelf.kconfig
#
+# waf host tool
+#
+source packages/htools/waf/waf.kconfig
+
+#
# zlib for host
#
source packages/htools/zlib/zlib.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index cb66b4c..4e20bdb 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -42,6 +42,10 @@ $(call embtk_include_hostpkg,pkgconf_host)
# squashfs
$(call embtk_include_hostpkg,squashfs_host)
+# waf
+include packages/htools/waf/vars.mk
+$(call embtk_include_hostpkg,waf_host)
+
# zlib
$(call embtk_include_hostpkg,zlib_host)
diff --git a/packages/htools/waf/vars.mk b/packages/htools/waf/vars.mk
new file mode 100644
index 0000000..9c35d61
--- /dev/null
+++ b/packages/htools/waf/vars.mk
@@ -0,0 +1 @@
+embtk_waf := $(embtk_htools)/usr/bin/waf
diff --git a/packages/htools/waf/waf.kconfig b/packages/htools/waf/waf.kconfig
new file mode 100644
index 0000000..debdac7
--- /dev/null
+++ b/packages/htools/waf/waf.kconfig
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file waf.kconfig
+# \brief waf.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2014
+################################################################################
+
+config EMBTK_HOST_HAVE_WAF
+ bool
+
+config EMBTK_WAF_HOST_VERSION_STRING
+ string
+ default "1.7.16"
diff --git a/packages/htools/waf/waf.mk b/packages/htools/waf/waf.mk
new file mode 100644
index 0000000..bd92d1f
--- /dev/null
+++ b/packages/htools/waf/waf.mk
@@ -0,0 +1,48 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file waf.mk
+# \brief waf.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2014
+################################################################################
+
+WAF_HOST_NAME := waf
+WAF_HOST_VERSION := $(call embtk_get_pkgversion,waf_host)
+WAF_HOST_SITE := http://ftp.waf.io/pub/release
+WAF_HOST_PACKAGE := waf-$(WAF_HOST_VERSION)
+WAF_HOST_SRC_DIR := $(embtk_toolsb)/waf-$(WAF_HOST_VERSION)
+WAF_HOST_BUILD_DIR := $(embtk_toolsb)/waf-$(WAF_HOST_VERSION)
+
+define embtk_download_waf_host
+ [ -e $(embtk_dldir)/$(WAF_HOST_PACKAGE) ] || \
+ $(call embtk_wget,$(WAF_HOST_PACKAGE),$(WAF_HOST_SITE))
+endef
+
+define embtk_install_waf_host
+ $(embtk_download_waf_host)
+ [ -e $(embtk_waf) ] || $(embtk_postinstallonce_waf_host)
+endef
+
+define embtk_postinstallonce_waf_host
+ install -D -m 0755 $(embtk_dldir)/$(WAF_HOST_PACKAGE) $(embtk_waf)
+endef
+
+download_waf_host waf_host_download:
+ $(embtk_download_waf_host)