summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-03-19 22:19:07 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-03-19 22:19:07 +0100
commitf3c805bcad4d92d971d3f6f50da1cfe886f69fd6 (patch)
tree7c6fb1f07a7d574ccae0b736021b89ba3a3f679f /packages/htools
parent13b06c297ebbf63be00f725894391630c5d516bc (diff)
downloadembtoolkit-f3c805bcad4d92d971d3f6f50da1cfe886f69fd6.tar.gz
embtoolkit-f3c805bcad4d92d971d3f6f50da1cfe886f69fd6.tar.bz2
embtoolkit-f3c805bcad4d92d971d3f6f50da1cfe886f69fd6.tar.xz
Host tools: move squashfs tools to packages/htools/
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/hosttools-buildopts.mk6
-rw-r--r--packages/htools/squashfs/squashfs.kconfig61
-rw-r--r--packages/htools/squashfs/squashfs.mk63
3 files changed, 130 insertions, 0 deletions
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index 31527c4..a7606c4 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -39,5 +39,11 @@ $(call embtk_include_hostpkg,mtdutils_host)
include packages/htools/pkgconf/vars.mk
$(call embtk_include_hostpkg,pkgconf_host)
+# squashfs
+$(call embtk_include_hostpkg,squashfs_host)
+
# zlib
$(call embtk_include_hostpkg,zlib_host)
+
+testinstall:
+ @echo $(call __embtk_pkg_confchanged-y,squashfs_host)
diff --git a/packages/htools/squashfs/squashfs.kconfig b/packages/htools/squashfs/squashfs.kconfig
new file mode 100644
index 0000000..67cee3a
--- /dev/null
+++ b/packages/htools/squashfs/squashfs.kconfig
@@ -0,0 +1,61 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file squashfs.kconfig
+# \brief squashfs.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date August 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_SQUASHFS
+ bool "Have squashfs host tools"
+ select EMBK_HOST_HAVE_ZLIB
+ help
+ Say Y to build host tools needed to generate squashfs
+ filesystem.
+
+ Squashfs is a compressed read-only filesystem for Linux.
+ Squashfs is intended for general read-only filesystem use,
+ for archival use (i.e. in cases where a .tar.gz file may be
+ used), and in constrained block device/memory systems
+ (e.g. embedded systems) where low overhead is needed.
+
+choice
+ prompt "squashfs tool version you wish"
+ depends on EMBTK_HOST_HAVE_SQUASHFS
+ help
+ Here you can choose which version of squashfs you want to use.
+
+ config EMBTK_SQUASHFS_HOST_VERSION_4_2
+ bool "squashfs4.2"
+ select EMBTK_SQUASHFS_HOST_NEED_PATCH
+ config EMBTK_SQUASHFS_HOST_VERSION_3_4
+ bool "squashfs3.4"
+ select EMBTK_SQUASHFS_HOST_NEED_PATCH
+endchoice
+
+config EMBTK_SQUASHFS_HOST_VERSION_STRING
+ string
+ default "4.2" if EMBTK_SQUASHFS_HOST_VERSION_4_2
+ default "3.4" if EMBTK_SQUASHFS_HOST_VERSION_3_4
+
+config EMBTK_SQUASHFS_HOST_NEED_PATCH
+ bool
+config EMBTK_SQUASHFS_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/squashfs/squashfs.mk b/packages/htools/squashfs/squashfs.mk
new file mode 100644
index 0000000..a221d76
--- /dev/null
+++ b/packages/htools/squashfs/squashfs.mk
@@ -0,0 +1,63 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file squashfs.mk
+# \brief squashfs.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date August 2009
+################################################################################
+
+SQUASHFS_HOST_NAME := squashfs
+SQUASHFS_HOST_VERSION := $(call embtk_get_pkgversion,squashfs_host)
+SQUASHFS_HOST_SITE := http://sourceforge.net/projects/squashfs/files/squashfs/squashfs$(SQUASHFS_HOST_VERSION)
+SQUASHFS_HOST_PACKAGE := squashfs$(SQUASHFS_HOST_VERSION).tar.gz
+SQUASHFS_HOST_SRC_DIR := $(embtk_toolsb)/squashfs$(SQUASHFS_HOST_VERSION)
+SQUASHFS_HOST_BUILD_DIR := $(embtk_toolsb)/squashfs-$(SQUASHFS_HOST_VERSION)-build
+
+MKSQUASHFS_BIN := $(embtk_htools)/usr/bin/mksquashfs
+UNSQUASHFS_BIN := $(embtk_htools)/usr/bin/unsquashfs
+
+SQUASHFS_HOST_DEPS := zlib_host_install
+
+# Build cppflags
+__embtk_squashfs_cppflags := -I$(embtk_htools)/usr/include
+ifneq ($(embtk_buildhost_os),linux)
+__embtk_squashfs_cppflags += -DFNM_EXTMATCH=0
+endif
+
+SQUASHFS_HOST_MAKE_ENV := CC=$(HOSTCC_CACHED)
+SQUASHFS_HOST_MAKE_ENV += CPPFLAGS="$(__embtk_squashfs_cppflags)"
+SQUASHFS_HOST_MAKE_ENV += LDFLAGS="-L$(embtk_htools)/usr/lib"
+SQUASHFS_HOST_MAKE_ENV += EXTRA_CFLAGS="-include sys/stat.h"
+
+SQUASHFS_HOST_MAKE_OPTS := XATTR_SUPPORT=0
+SQUASHFS_HOST_MAKE_OPTS += INSTALL_DIR="$(embtk_htools)/usr/bin"
+
+define embtk_beforeinstall_squashfs_host
+ rm -rf $(SQUASHFS_HOST_BUILD_DIR)
+ ln -sf $(SQUASHFS_HOST_SRC_DIR)/squashfs-tools $(SQUASHFS_HOST_BUILD_DIR)
+endef
+
+define embtk_install_squashfs_host
+ $(call embtk_makeinstall_hostpkg,squashfs_host)
+endef
+
+define embtk_cleanup_squashfs_tools
+ rm -rf $(SQUASHFS_HOST_SRC_DIR)
+endef