summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:00:18 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 21:00:18 +0200
commitf5286d55871178d127a030023f6960aefc502d71 (patch)
treee578a8640d583fedde066634cf282347d754afaa /packages/htools
parenta0831fa1c284bc78f46a4062a812ac9af71d682f (diff)
downloadembtoolkit-f5286d55871178d127a030023f6960aefc502d71.tar.gz
embtoolkit-f5286d55871178d127a030023f6960aefc502d71.tar.bz2
embtoolkit-f5286d55871178d127a030023f6960aefc502d71.tar.xz
Host tools: move m4 to htools/m4
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/hosttools-buildopts.kconfig2
-rw-r--r--packages/htools/hosttools-buildopts.mk3
-rw-r--r--packages/htools/m4/m4.kconfig40
-rw-r--r--packages/htools/m4/m4.mk31
-rw-r--r--packages/htools/m4/vars.mk30
5 files changed, 105 insertions, 1 deletions
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 5dac98a..4541439 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -102,7 +102,7 @@ source packages/htools/ccache/ccache.kconfig
#
# Autotools
#
-source core/kconfig/m4.kconfig
+source packages/htools/m4/m4.kconfig
source core/kconfig/libtool.kconfig
source core/kconfig/autoconf.kconfig
source core/kconfig/automake.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index cb66b4c..c7be0ad 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -35,6 +35,9 @@ $(call embtk_include_hostpkg,fakeroot_host)
# mtd-utils
$(call embtk_include_hostpkg,mtdutils_host)
+# m4
+$(call embtk_include_hostpkg,m4_host)
+
# pkgconf
include packages/htools/pkgconf/vars.mk
$(call embtk_include_hostpkg,pkgconf_host)
diff --git a/packages/htools/m4/m4.kconfig b/packages/htools/m4/m4.kconfig
new file mode 100644
index 0000000..1a9a5c9
--- /dev/null
+++ b/packages/htools/m4/m4.kconfig
@@ -0,0 +1,40 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file m4.kconfig
+# \brief m4.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_M4
+ bool
+ default y
+ select EMBTK_M4_HOST_NEED_PATCH
+ help
+ m4 for autotools.
+
+config EMBTK_M4_HOST_VERSION_STRING
+ string
+ default "1.4.17"
+
+config EMBTK_M4_HOST_NEED_PATCH
+ bool
+config EMBTK_M4_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/m4/m4.mk b/packages/htools/m4/m4.mk
new file mode 100644
index 0000000..e09b31e
--- /dev/null
+++ b/packages/htools/m4/m4.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2013 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file m4.mk
+# \brief m4.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+M4_HOST_NAME := m4
+M4_HOST_VERSION := $(call embtk_get_pkgversion,m4_host)
+M4_HOST_SITE := http://ftp.gnu.org/gnu/m4
+M4_HOST_PACKAGE := m4-$(M4_HOST_VERSION).tar.bz2
+M4_HOST_SRC_DIR := $(embtk_toolsb)/m4-$(M4_HOST_VERSION)
+M4_HOST_BUILD_DIR := $(embtk_toolsb)/m4-$(M4_HOST_VERSION)
diff --git a/packages/htools/m4/vars.mk b/packages/htools/m4/vars.mk
new file mode 100644
index 0000000..564e30c
--- /dev/null
+++ b/packages/htools/m4/vars.mk
@@ -0,0 +1,30 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2013 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file vars.mk
+# \brief vars.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+# m4 binaries
+M4_DIR := $(embtk_htools)/usr
+M4_BIN := $(M4_DIR)/bin/m4
+M4 := $(M4_BIN)
+export M4