summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-17 23:47:48 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-17 23:54:30 +0100
commit95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220 (patch)
tree8ade3da127195f4ee35f051e286075d78cfe82bc /packages/misc
parenta16b2770979813e7f1869dda084a82a131f8c734 (diff)
downloadembtoolkit-95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220.tar.gz
embtoolkit-95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220.tar.bz2
embtoolkit-95b7b617b53eb2b6a33fa4cd2d9ed3c404d2c220.tar.xz
Packages: Rework build process and use foo-y targets
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/misc.mk66
1 files changed, 66 insertions, 0 deletions
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
new file mode 100644
index 0000000..844eabb
--- /dev/null
+++ b/packages/misc/misc.mk
@@ -0,0 +1,66 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file misc.mk
+# \brief misc.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date February 2010
+################################################################################
+
+#gettext
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GETTEXT) += gettext_install
+ROOTFS_COMPONENTS_CLEAN += gettext_clean
+ifeq ($(CONFIG_EMBTK_HAVE_GETTEXT),y)
+include $(EMBTK_ROOT)/packages/misc/gettext/gettext.mk
+endif
+
+#GLib
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GLIB) += glib_install
+ROOTFS_COMPONENTS_CLEAN += glib_clean
+ifeq ($(CONFIG_EMBTK_HAVE_GLIB),y)
+include $(EMBTK_ROOT)/packages/misc/glib/glib.mk
+endif
+
+#libelf
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBELF) += libelf_install
+ROOTFS_COMPONENTS_CLEAN += libelf_clean
+ifeq ($(CONFIG_EMBTK_HAVE_LIBELF),y)
+include $(EMBTK_ROOT)/packages/misc/libelf/libelf.mk
+endif
+
+#libxml2
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBXML2) += libxml2_install
+ROOTFS_COMPONENTS_CLEAN += libxml2_clean
+ifeq ($(CONFIG_EMBTK_HAVE_LIBXML2),y)
+include $(EMBTK_ROOT)/packages/misc/libxml/libxml.mk
+endif
+
+#ncurses
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_NCURSES) += ncurses_install
+ROOTFS_COMPONENTS_CLEAN += ncurses_clean
+ifeq ($(CONFIG_EMBTK_HAVE_NCURSES),y)
+include $(EMBTK_ROOT)/packages/misc/ncurses/ncurses.mk
+endif
+
+#Pango
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_PANGO) += pango_install
+ROOTFS_COMPONENTS_CLEAN += pango_clean
+ifeq ($(CONFIG_EMBTK_HAVE_PANGO),y)
+include $(EMBTK_ROOT)/packages/misc/pango/pango.mk
+endif
+