summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-23 15:43:40 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-23 15:45:45 +0100
commit1c0a187555fbad7be859015a45f00c97bec6a424 (patch)
tree80f7a09718483cdeaab547ccb74d87d35047cdb5 /packages/misc
parent2f0f628ba3a00be486fd011154fba7a7f5d7081f (diff)
downloadembtoolkit-1c0a187555fbad7be859015a45f00c97bec6a424.tar.gz
embtoolkit-1c0a187555fbad7be859015a45f00c97bec6a424.tar.bz2
embtoolkit-1c0a187555fbad7be859015a45f00c97bec6a424.tar.xz
Packages: new glib: add glib as buildable package
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/glib/glib.kconfig58
-rw-r--r--packages/misc/glib/glib.mk89
2 files changed, 147 insertions, 0 deletions
diff --git a/packages/misc/glib/glib.kconfig b/packages/misc/glib/glib.kconfig
new file mode 100644
index 0000000..395428d
--- /dev/null
+++ b/packages/misc/glib/glib.kconfig
@@ -0,0 +1,58 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file glib.kconfig
+# \brief glib.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date December 2009
+################################################################################
+
+config EMBTK_HAVE_GLIB
+ bool "Have GLib"
+ select EMBTK_HAVE_GETTEXT
+ help
+ GLib is a general-purpose utility library, which provides many
+ useful data types, macros, type conversions, string utilities,
+ file utilities, a main loop abstraction, and so on. It works on
+ many UNIX-like platforms, Windows, OS/2 and BeOS. GLib is
+ released under the GNU Library General Public License
+ (GNU LGPL).
+ The general policy of GLib is that all functions are invisibly
+ threadsafe with the exception of data structure manipulation
+ functions, where, if you have two threads manipulating the same
+ data structure, they must use a lock to synchronize their
+ operation.
+choice
+ prompt "GLib version you wish"
+ default EMBTK_GLIB_VERSION_2_23_1
+ depends on EMBTK_HAVE_GLIB
+ help
+ Here you can choose which version of GLib you want to use.
+
+ config EMBTK_GLIB_VERSION_2_23_1
+ bool "GLib-2.23.1"
+endchoice
+
+config EMBTK_GLIB_MAJOR_VERSION_STRING
+ string
+ default "2.23" if EMBTK_GLIB_VERSION_2_23_1
+
+config EMBTK_GLIB_VERSION_STRING
+ string
+ default "2.23.1" if EMBTK_GLIB_VERSION_2_23_1
+
diff --git a/packages/misc/glib/glib.mk b/packages/misc/glib/glib.mk
new file mode 100644
index 0000000..a759b3d
--- /dev/null
+++ b/packages/misc/glib/glib.mk
@@ -0,0 +1,89 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file glib.mk
+# \brief glib.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date December 2009
+################################################################################
+
+GLIB_MAJOR_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_GLIB_MAJOR_VERSION_STRING)))
+GLIB_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_GLIB_VERSION_STRING)))
+GLIB_SITE := http://ftp.gnome.org/pub/gnome/sources/glib/$(GLIB_MAJOR_VERSION)
+GLIB_PACKAGE := glib-$(GLIB_VERSION).tar.bz2
+GLIB_BUILD_DIR := $(PACKAGES_BUILD)/glib-$(GLIB_VERSION)
+
+GLIB_BINS = glib-genmarshal glib-gettextize glib-mkenums gobject-query \
+ gtester gtester-report
+GLIB_SBINS =
+GLIB_INCLUDES = gio-unix-* glib-*
+GLIB_LIBS = gio* libgio-* libglib-* libgmodule-* libgobject-* libgthread-*
+GLIB_PKGCONFIGS = gio-*.pc glib-*.pc gmodule-*.pc gobject-*.pc gthread-*.pc
+
+glib_install: $(GLIB_BUILD_DIR)/.installed
+
+$(GLIB_BUILD_DIR)/.installed: download_glib \
+ $(GLIB_BUILD_DIR)/.decompressed $(GLIB_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ glib-$(GLIB_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(GLIB_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(GLIB_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ @touch $@
+
+download_glib:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(GLIB_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(GLIB_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(GLIB_PACKAGE) \
+ $(GLIB_SITE)/$(GLIB_PACKAGE)
+
+$(GLIB_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(GLIB_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(GLIB_PACKAGE)
+ @touch $@
+
+$(GLIB_BUILD_DIR)/.configured:
+ $(Q)cd $(GLIB_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) CXX=$(TARGETCXX_CACHED) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/lib -L$(SYSROOT)/usr/lib \
+ -L$(SYSROOT)/lib32 -L$(SYSROOT)/usr/lib32" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ glib_cv_stack_grows=no \
+ glib_cv_uscore=yes \
+ ac_cv_func_posix_getpwuid_r=yes \
+ ac_cv_func_nonposix_getpwuid_r=no \
+ ac_cv_func_posix_getgrgid_r=yes \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) \
+ --prefix=/usr --disable-fam
+ @touch $@
+
+glib_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup glib-$(GLIB_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(GLIB_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(GLIB_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(GLIB_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(GLIB_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(GLIB_PKGCONFIGS)
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+ $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(GLIB_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(GLIB_PKGCONFIGS)
+endif
+