summaryrefslogtreecommitdiff
path: root/packages/system
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-28 15:37:49 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-28 15:37:49 +0200
commit305b54a1a103f33f552c9693fbe1a0b801855c9c (patch)
tree59dc9be69d2b1d16649272efc2dcc5bc8c71ffd3 /packages/system
parent53b4522531e73e8546592ed5713d6933f35fd6c0 (diff)
downloadembtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.gz
embtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.bz2
embtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.xz
Packages: massively convert to use generic macros and implicit rules
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/system')
-rw-r--r--packages/system/dbus/dbus.mk49
-rw-r--r--packages/system/e2fsprogs/e2fsprogs.mk30
2 files changed, 24 insertions, 55 deletions
diff --git a/packages/system/dbus/dbus.mk b/packages/system/dbus/dbus.mk
index 51638dd..fc68e9a 100644
--- a/packages/system/dbus/dbus.mk
+++ b/packages/system/dbus/dbus.mk
@@ -23,40 +23,27 @@
# \date July 2010
################################################################################
-DBUS_NAME := dbus
-DBUS_VERSION := $(call embtk_get_pkgversion,DBUS)
-DBUS_SITE := http://dbus.freedesktop.org/releases/dbus
-DBUS_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
-DBUS_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/dbus/$(DBUS_VERSION)
-DBUS_PACKAGE := dbus-$(DBUS_VERSION).tar.gz
-DBUS_SRC_DIR := $(PACKAGES_BUILD)/dbus-$(DBUS_VERSION)
-DBUS_BUILD_DIR := $(PACKAGES_BUILD)/dbus-$(DBUS_VERSION)
-
-DBUS_BINS = dbus-cleanup-sockets dbus-daemon dbus-launch dbus-monitor \
- dbus-send dbus-uuidgen
-DBUS_SBINS =
-DBUS_INCLUDES = dbus-*
-DBUS_LIBS = dbus-* libdbus*
-DBUS_PKGCONFIGS = dbus*.pc
-
-DBUS_DEPS = expat_install \
- $(if $(CONFIG_EMBTK_HAVE_LIBX11),libx11_install,)
+DBUS_NAME := dbus
+DBUS_VERSION := $(call embtk_get_pkgversion,dbus)
+DBUS_SITE := http://dbus.freedesktop.org/releases/dbus
+DBUS_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+DBUS_PACKAGE := dbus-$(DBUS_VERSION).tar.gz
+DBUS_SRC_DIR := $(PACKAGES_BUILD)/dbus-$(DBUS_VERSION)
+DBUS_BUILD_DIR := $(PACKAGES_BUILD)/dbus-$(DBUS_VERSION)
+
+DBUS_BINS = dbus-cleanup-sockets dbus-daemon dbus-launch \
+ dbus-monitor dbus-send dbus-uuidgen
+DBUS_SBINS =
+DBUS_INCLUDES = dbus-*
+DBUS_LIBS = dbus-* libdbus*
+DBUS_PKGCONFIGS = dbus*.pc
+
+DBUS_DEPS = expat_install $(if $(CONFIG_EMBTK_HAVE_LIBX11),libx11_install)
DBUS_CONFIGURE_OPTS := --enable-abstract-sockets \
$(if $(CONFIG_EMBTK_HAVE_LIBX11),--with-x,--without-x)
-dbus_install:
- $(call embtk_install_pkg,DBUS)
- $(Q)$(MAKE) $(DBUS_BUILD_DIR)/.special
-
-download_dbus:
- $(call embtk_download_pkg,DBUS)
-
-dbus_clean:
- $(call embtk_cleanup_pkg,DBUS)
-
-.PHONY: $(DBUS_BUILD_DIR)/.special dbus_clean
-
-$(DBUS_BUILD_DIR)/.special:
+define embtk_postinstall_dbus
$(Q)-mkdir -p $(ROOTFS)/usr/libexec
$(Q)-cp -R $(SYSROOT)/usr/libexec/dbus* $(ROOTFS)/usr/libexec/
+endef
diff --git a/packages/system/e2fsprogs/e2fsprogs.mk b/packages/system/e2fsprogs/e2fsprogs.mk
index d5f753b..8e8ffce 100644
--- a/packages/system/e2fsprogs/e2fsprogs.mk
+++ b/packages/system/e2fsprogs/e2fsprogs.mk
@@ -24,10 +24,9 @@
################################################################################
E2FSPROGS_NAME := e2fsprogs
-E2FSPROGS_VERSION := $(call embtk_get_pkgversion,E2FSPROGS)
+E2FSPROGS_VERSION := $(call embtk_get_pkgversion,e2fsprogs)
E2FSPROGS_SITE := http://sourceforge.net/projects/e2fsprogs/files/e2fsprogs/$(E2FSPROGS_VERSION)
E2FSPROGS_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
-E2FSPROGS_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/e2fsprogs/$(E2FSPROGS_VERSION)
E2FSPROGS_PACKAGE := e2fsprogs-$(E2FSPROGS_VERSION).tar.gz
E2FSPROGS_SRC_DIR := $(PACKAGES_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
E2FSPROGS_BUILD_DIR := $(PACKAGES_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
@@ -48,17 +47,8 @@ E2FSPROGS_CONFIGURE_OPTS := --disable-compression --disable-htree \
--disable-blkid-debug --disable-testio-debug \
--enable-libuuid --enable-libblkid --disable-debugfs \
--disable-imager --disable-resizer --disable-fsck \
- --disable-e2initrd-helper --disable-tls --disable-tls \
- --disable-nls --disable-rpath --with-included-gettext
-
-e2fsprogs_install:
- $(call embtk_install_pkg,E2FSPROGS)
-
-download_e2fsprogs:
- $(call embtk_download_pkg,E2FSPROGS)
-
-e2fsprogs_clean:
- $(call embtk_cleanup_pkg,E2FSPROGS)
+ --disable-e2initrd-helper --disable-tls --disable-nls \
+ --disable-rpath --with-included-gettext
#
# E2FSPROGS for host development machine
@@ -67,19 +57,11 @@ E2FSPROGS_HOST_NAME := $(E2FSPROGS_NAME)
E2FSPROGS_HOST_VERSION := $(E2FSPROGS_VERSION)
E2FSPROGS_HOST_SITE := $(E2FSPROGS_SITE)
E2FSPROGS_HOST_SITE_MIRROR3 := $(E2FSPROGS_SITE_MIRROR3)
-E2FSPROGS_HOST_PATCH_SITE := $(E2FSPROGS_PATCH_SITE)
E2FSPROGS_HOST_PACKAGE := $(E2FSPROGS_PACKAGE)
E2FSPROGS_HOST_SRC_DIR := $(TOOLS_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
E2FSPROGS_HOST_BUILD_DIR := $(TOOLS_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
-E2FSPROGS_HOST_MAKE_OPTS := LDCONFIG=true
-E2FSPROGS_HOST_MAKE_DIRS := $(E2FSPROGS_MAKE_DIRS)
-E2FSPROGS_CONFIGURE_OPTS := $(E2FSPROGS_CONFIGURE_OPTS)
-
-e2fsprogs_host_install:
- $(call embtk_install_hostpkg,E2FSPROGS_HOST)
-
-download_e2fsprogs_host:
- $(call embtk_download_pkg,E2FSPROGS_HOST)
+E2FSPROGS_HOST_MAKE_OPTS := LDCONFIG=true
+E2FSPROGS_HOST_MAKE_DIRS := $(E2FSPROGS_MAKE_DIRS)
+E2FSPROGS_HOST_CONFIGURE_OPTS := $(E2FSPROGS_CONFIGURE_OPTS)
-e2fsprogs_host_clean: