summaryrefslogtreecommitdiff
path: root/packages/x11/bigreqsproto
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:09:24 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:14:30 +0100
commit48b82779acbe28349d2111a86ac2dde95adb59fd (patch)
treece91bf48d1e5e66ed93711f0ecd89be10b45d530 /packages/x11/bigreqsproto
parentfeb16c4606efa24684e451e4db7d14d9864b5afe (diff)
downloadembtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.gz
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.bz2
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.xz
Packages: X Windowing system: Massive X windowing system packages introduction
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/x11/bigreqsproto')
-rw-r--r--packages/x11/bigreqsproto/bigreqsproto.kconfig43
-rw-r--r--packages/x11/bigreqsproto/bigreqsproto.mk94
2 files changed, 137 insertions, 0 deletions
diff --git a/packages/x11/bigreqsproto/bigreqsproto.kconfig b/packages/x11/bigreqsproto/bigreqsproto.kconfig
new file mode 100644
index 0000000..06bc824
--- /dev/null
+++ b/packages/x11/bigreqsproto/bigreqsproto.kconfig
@@ -0,0 +1,43 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file bigreqsproto.kconfig
+# \brief bigreqsproto.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date February 2010
+################################################################################
+
+config EMBTK_HAVE_BIGREQSPROTO
+ bool "Have bigreqsproto"
+ help
+ bigreqsproto for X windowing system
+choice
+ prompt "bigreqsproto version you wish"
+ depends on EMBTK_HAVE_BIGREQSPROTO
+ help
+ Here you can choose which version of bigreqsproto you want to
+ use.
+
+ config EMBTK_BIGREQSPROTO_VERSION_1_1_0
+ bool "bigreqsproto-1.1.0"
+endchoice
+
+config EMBTK_BIGREQSPROTO_VERSION_STRING
+ string
+ default "1.1.0" if EMBTK_BIGREQSPROTO_VERSION_1_1_0
+
diff --git a/packages/x11/bigreqsproto/bigreqsproto.mk b/packages/x11/bigreqsproto/bigreqsproto.mk
new file mode 100644
index 0000000..45c9e16
--- /dev/null
+++ b/packages/x11/bigreqsproto/bigreqsproto.mk
@@ -0,0 +1,94 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file bigreqsproto.mk
+# \brief bigreqsproto.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date February 2010
+################################################################################
+
+BIGREQSPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_BIGREQSPROTO_VERSION_STRING)))
+BIGREQSPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
+BIGREQSPROTO_PACKAGE := bigreqsproto-$(BIGREQSPROTO_VERSION).tar.bz2
+BIGREQSPROTO_BUILD_DIR := $(PACKAGES_BUILD)/bigreqsproto-$(BIGREQSPROTO_VERSION)
+
+BIGREQSPROTO_BINS =
+BIGREQSPROTO_SBINS =
+BIGREQSPROTO_INCLUDES = X11/extensions/bigreqsproto.h X11/extensions/bigreqstr.h
+BIGREQSPROTO_LIBS =
+BIGREQSPROTO_PKGCONFIGS = bigreqsproto.pc
+
+bigreqsproto_install: $(BIGREQSPROTO_BUILD_DIR)/.installed
+
+$(BIGREQSPROTO_BUILD_DIR)/.installed: download_bigreqsproto \
+ $(BIGREQSPROTO_BUILD_DIR)/.decompressed $(BIGREQSPROTO_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ bigreqsproto-$(BIGREQSPROTO_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(BIGREQSPROTO_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(BIGREQSPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_bigreqsproto:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(BIGREQSPROTO_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(BIGREQSPROTO_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(BIGREQSPROTO_PACKAGE) \
+ $(BIGREQSPROTO_SITE)/$(BIGREQSPROTO_PACKAGE)
+
+$(BIGREQSPROTO_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(BIGREQSPROTO_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(BIGREQSPROTO_PACKAGE)
+ @touch $@
+
+$(BIGREQSPROTO_BUILD_DIR)/.configured:
+ $(Q)cd $(BIGREQSPROTO_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) \
+ --prefix=/usr --libdir=/usr/$(LIBDIR)
+ @touch $@
+
+bigreqsproto_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup bigreqsproto-$(BIGREQSPROTO_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(BIGREQSPROTO_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(BIGREQSPROTO_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(BIGREQSPROTO_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(BIGREQSPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(BIGREQSPROTO_PKGCONFIGS)
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+ $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(BIGREQSPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(BIGREQSPROTO_PKGCONFIGS)
+endif
+