summaryrefslogtreecommitdiff
path: root/packages/x11/fontsproto/fontsproto.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/x11/fontsproto/fontsproto.mk
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/fontsproto/fontsproto.mk')
-rw-r--r--packages/x11/fontsproto/fontsproto.mk25
1 files changed, 9 insertions, 16 deletions
diff --git a/packages/x11/fontsproto/fontsproto.mk b/packages/x11/fontsproto/fontsproto.mk
index 94c3561..6857da6 100644
--- a/packages/x11/fontsproto/fontsproto.mk
+++ b/packages/x11/fontsproto/fontsproto.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,7 +19,7 @@
#
# \file fontsproto.mk
# \brief fontsproto.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date February 2010
################################################################################
@@ -36,13 +36,9 @@ FONTSPROTO_INCLUDES = X11/fonts/font.h X11/fonts/fontproto.h \
FONTSPROTO_LIBS =
FONTSPROTO_PKGCONFIGS = fontsproto.pc
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
-else
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
-endif
-
-fontsproto_install: $(FONTSPROTO_BUILD_DIR)/.installed
+fontsproto_install:
+ @test -e $(FONTSPROTO_BUILD_DIR)/.installed || \
+ $(MAKE) $(FONTSPROTO_BUILD_DIR)/.installed
$(FONTSPROTO_BUILD_DIR)/.installed: download_fontsproto \
$(FONTSPROTO_BUILD_DIR)/.decompressed $(FONTSPROTO_BUILD_DIR)/.configured
@@ -90,14 +86,11 @@ $(FONTSPROTO_BUILD_DIR)/.configured:
@touch $@
fontsproto_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup fontsproto-$(FONTSPROTO_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup fontsproto...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(FONTSPROTO_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(FONTSPROTO_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(FONTSPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(FONTSPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(FONTSPROTO_PKGCONFIGS)
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(FONTSPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(FONTSPROTO_PKGCONFIGS)
-endif
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(FONTSPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(FONTSPROTO_PKGCONFIGS)
+ $(Q)-rm -rf $(FONTSPROTO_BUILD_DIR)