summaryrefslogtreecommitdiff
path: root/packages/x11/fontsproto/fontsproto.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
commitfc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5 (patch)
treef0f854815e87328a3f8c749210b2f793d0eaf602 /packages/x11/fontsproto/fontsproto.mk
parentdc8ad05cccf64348b9235bd6aabed302b12ae3ab (diff)
downloadembtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.gz
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.bz2
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.xz
Packages: convert more (almost all) packages to generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/fontsproto/fontsproto.mk')
-rw-r--r--packages/x11/fontsproto/fontsproto.mk84
1 files changed, 14 insertions, 70 deletions
diff --git a/packages/x11/fontsproto/fontsproto.mk b/packages/x11/fontsproto/fontsproto.mk
index 18fdf66..a6d7b9e 100644
--- a/packages/x11/fontsproto/fontsproto.mk
+++ b/packages/x11/fontsproto/fontsproto.mk
@@ -23,74 +23,18 @@
# \date February 2010
################################################################################
-FONTSPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_FONTSPROTO_VERSION_STRING)))
-FONTSPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
-FONTSPROTO_PACKAGE := fontsproto-$(FONTSPROTO_VERSION).tar.bz2
-FONTSPROTO_BUILD_DIR := $(PACKAGES_BUILD)/fontsproto-$(FONTSPROTO_VERSION)
-
-FONTSPROTO_BINS =
-FONTSPROTO_SBINS =
-FONTSPROTO_INCLUDES = X11/fonts/font.h X11/fonts/fontproto.h \
- X11/fonts/fontstruct.h X11/fonts/FS.h X11/fonts/fsmasks.h \
- X11/fonts/FSproto.h
-FONTSPROTO_LIBS =
-FONTSPROTO_PKGCONFIGS = fontsproto.pc
-
-fontsproto_install:
- @test -e $(FONTSPROTO_BUILD_DIR)/.installed || \
- $(MAKE) $(FONTSPROTO_BUILD_DIR)/.installed
-
-$(FONTSPROTO_BUILD_DIR)/.installed: download_fontsproto \
- $(FONTSPROTO_BUILD_DIR)/.decompressed $(FONTSPROTO_BUILD_DIR)/.configured
- $(call embtk_generic_message,"Compiling and installing \
- fontsproto-$(FONTSPROTO_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(FONTSPROTO_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(FONTSPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
-
-download_fontsproto:
- $(call embtk_generic_message,"Downloading $(FONTSPROTO_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(FONTSPROTO_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(FONTSPROTO_PACKAGE) \
- $(FONTSPROTO_SITE)/$(FONTSPROTO_PACKAGE)
-
-$(FONTSPROTO_BUILD_DIR)/.decompressed:
- $(call embtk_generic_message,"Decompressing $(FONTSPROTO_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(FONTSPROTO_PACKAGE)
- @touch $@
-
-$(FONTSPROTO_BUILD_DIR)/.configured:
- $(Q)cd $(FONTSPROTO_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLGAS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(EMBTK_PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --prefix=/usr --libdir=/usr/$(LIBDIR) \
- --disable-malloc0returnsnull
- @touch $@
-
-fontsproto_clean:
- $(call embtk_generic_message,"cleanup fontsproto...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(FONTSPROTO_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(FONTSPROTO_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(FONTSPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(FONTSPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(FONTSPROTO_PKGCONFIGS)
- $(Q)-rm -rf $(FONTSPROTO_BUILD_DIR)*
+FONTSPROTO_NAME := fontsproto
+FONTSPROTO_VERSION := $(call embtk_get_pkgversion,fontsproto)
+FONTSPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
+FONTSPROTO_PACKAGE := fontsproto-$(FONTSPROTO_VERSION).tar.bz2
+FONTSPROTO_SRC_DIR := $(PACKAGES_BUILD)/fontsproto-$(FONTSPROTO_VERSION)
+FONTSPROTO_BUILD_DIR := $(PACKAGES_BUILD)/fontsproto-$(FONTSPROTO_VERSION)
+
+FONTSPROTO_BINS =
+FONTSPROTO_SBINS =
+FONTSPROTO_INCLUDES = X11/fonts/font.h X11/fonts/fontproto.h \
+ X11/fonts/fontstruct.h X11/fonts/FS.h \
+ X11/fonts/fsmasks.h X11/fonts/FSproto.h
+FONTSPROTO_LIBS =
+FONTSPROTO_PKGCONFIGS = fontsproto.pc