summaryrefslogtreecommitdiff
path: root/packages/x11/libpthreadstubs/libpthreadstubs.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/x11/libpthreadstubs/libpthreadstubs.mk
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/libpthreadstubs/libpthreadstubs.mk')
-rw-r--r--packages/x11/libpthreadstubs/libpthreadstubs.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/packages/x11/libpthreadstubs/libpthreadstubs.mk b/packages/x11/libpthreadstubs/libpthreadstubs.mk
index 52165db..da54f8c 100644
--- a/packages/x11/libpthreadstubs/libpthreadstubs.mk
+++ b/packages/x11/libpthreadstubs/libpthreadstubs.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software; you can distribute it and/or modify it
# under the terms of the GNU General Public License
@@ -18,7 +18,7 @@
#
# \file libpthreadstubs.mk
# \brief libpthreadstubs.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date March 2010
################################################################################
@@ -33,7 +33,9 @@ LIBPTHREADSTUBS_INCLUDES =
LIBPTHREADSTUBS_LIBS =
LIBPTHREADSTUBS_PKGCONFIGS = pthread-stubs.pc
-libpthreadstubs_install: $(LIBPTHREADSTUBS_BUILD_DIR)/.installed
+libpthreadstubs_install:
+ @test -e $(LIBPTHREADSTUBS_BUILD_DIR)/.installed || \
+ $(MAKE) $(LIBPTHREADSTUBS_BUILD_DIR)/.installed
$(LIBPTHREADSTUBS_BUILD_DIR)/.installed: download_libpthreadstubs \
$(LIBPTHREADSTUBS_BUILD_DIR)/.decompressed $(LIBPTHREADSTUBS_BUILD_DIR)/.configured
@@ -87,4 +89,5 @@ libpthreadstubs_clean:
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBPTHREADSTUBS_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBPTHREADSTUBS_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBPTHREADSTUBS_PKGCONFIGS)
+ $(Q)-rm -rf $(LIBPTHREADSTUBS_BUILD_DIR)