summaryrefslogtreecommitdiff
path: root/packages/x11/libpthreadstubs
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:09:24 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:14:30 +0100
commit48b82779acbe28349d2111a86ac2dde95adb59fd (patch)
treece91bf48d1e5e66ed93711f0ecd89be10b45d530 /packages/x11/libpthreadstubs
parentfeb16c4606efa24684e451e4db7d14d9864b5afe (diff)
downloadembtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.gz
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.bz2
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.xz
Packages: X Windowing system: Massive X windowing system packages introduction
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/x11/libpthreadstubs')
-rw-r--r--packages/x11/libpthreadstubs/libpthreadstubs.kconfig42
-rw-r--r--packages/x11/libpthreadstubs/libpthreadstubs.mk90
2 files changed, 132 insertions, 0 deletions
diff --git a/packages/x11/libpthreadstubs/libpthreadstubs.kconfig b/packages/x11/libpthreadstubs/libpthreadstubs.kconfig
new file mode 100644
index 0000000..ec3931f
--- /dev/null
+++ b/packages/x11/libpthreadstubs/libpthreadstubs.kconfig
@@ -0,0 +1,42 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file libpthreadstubs.kconfig
+# \brief libpthreadstubs.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+config EMBTK_HAVE_LIBPTHREADSTUBS
+ bool "Have libpthreadstubs"
+ help
+ libpthreadstubs for X windowing system
+choice
+ prompt "libpthreadstubs version you wish"
+ depends on EMBTK_HAVE_LIBPTHREADSTUBS
+ help
+ Here you can choose which version of libpthreadstubs you want to use.
+
+ config EMBTK_LIBPTHREADSTUBS_VERSION_0_3
+ bool "libpthreadstubs-0.3"
+endchoice
+
+config EMBTK_LIBPTHREADSTUBS_VERSION_STRING
+ string
+ default "0.3" if EMBTK_LIBPTHREADSTUBS_VERSION_0_3
+
diff --git a/packages/x11/libpthreadstubs/libpthreadstubs.mk b/packages/x11/libpthreadstubs/libpthreadstubs.mk
new file mode 100644
index 0000000..c47b958
--- /dev/null
+++ b/packages/x11/libpthreadstubs/libpthreadstubs.mk
@@ -0,0 +1,90 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file libpthreadstubs.mk
+# \brief libpthreadstubs.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+LIBPTHREADSTUBS_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_LIBPTHREADSTUBS_VERSION_STRING)))
+LIBPTHREADSTUBS_SITE := http://xcb.freedesktop.org/dist
+LIBPTHREADSTUBS_PACKAGE := libpthread-stubs-$(LIBPTHREADSTUBS_VERSION).tar.bz2
+LIBPTHREADSTUBS_BUILD_DIR := $(PACKAGES_BUILD)/libpthread-stubs-$(LIBPTHREADSTUBS_VERSION)
+
+LIBPTHREADSTUBS_BINS =
+LIBPTHREADSTUBS_SBINS =
+LIBPTHREADSTUBS_INCLUDES =
+LIBPTHREADSTUBS_LIBS =
+LIBPTHREADSTUBS_PKGCONFIGS = pthread-stubs.pc
+
+libpthreadstubs_install: $(LIBPTHREADSTUBS_BUILD_DIR)/.installed
+
+$(LIBPTHREADSTUBS_BUILD_DIR)/.installed: download_libpthreadstubs \
+ $(LIBPTHREADSTUBS_BUILD_DIR)/.decompressed $(LIBPTHREADSTUBS_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ libpthreadstubs-$(LIBPTHREADSTUBS_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(LIBPTHREADSTUBS_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(LIBPTHREADSTUBS_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_libpthreadstubs:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(LIBPTHREADSTUBS_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(LIBPTHREADSTUBS_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(LIBPTHREADSTUBS_PACKAGE) \
+ $(LIBPTHREADSTUBS_SITE)/$(LIBPTHREADSTUBS_PACKAGE)
+
+$(LIBPTHREADSTUBS_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(LIBPTHREADSTUBS_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(LIBPTHREADSTUBS_PACKAGE)
+ @touch $@
+
+$(LIBPTHREADSTUBS_BUILD_DIR)/.configured:
+ $(Q)cd $(LIBPTHREADSTUBS_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) \
+ --prefix=/usr --libdir=/usr/$(LIBDIR)
+ @touch $@
+
+libpthreadstubs_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup libpthreadstubs-$(LIBPTHREADSTUBS_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(LIBPTHREADSTUBS_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(LIBPTHREADSTUBS_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBPTHREADSTUBS_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBPTHREADSTUBS_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBPTHREADSTUBS_PKGCONFIGS)
+