summaryrefslogtreecommitdiff
path: root/packages/x11/libxext
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:09:24 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:14:30 +0100
commit48b82779acbe28349d2111a86ac2dde95adb59fd (patch)
treece91bf48d1e5e66ed93711f0ecd89be10b45d530 /packages/x11/libxext
parentfeb16c4606efa24684e451e4db7d14d9864b5afe (diff)
downloadembtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.gz
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.bz2
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.xz
Packages: X Windowing system: Massive X windowing system packages introduction
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/x11/libxext')
-rw-r--r--packages/x11/libxext/libxext.kconfig43
-rw-r--r--packages/x11/libxext/libxext.mk101
2 files changed, 144 insertions, 0 deletions
diff --git a/packages/x11/libxext/libxext.kconfig b/packages/x11/libxext/libxext.kconfig
new file mode 100644
index 0000000..9ed0229
--- /dev/null
+++ b/packages/x11/libxext/libxext.kconfig
@@ -0,0 +1,43 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file libxext.kconfig
+# \brief libxext.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+config EMBTK_HAVE_LIBXEXT
+ bool "Have libXext"
+ select EMBTK_HAVE_LIBX11
+ help
+ libXext for X windowing system
+choice
+ prompt "libxext version you wish"
+ depends on EMBTK_HAVE_LIBXEXT
+ help
+ Here you can choose which version of libxext you want to use.
+
+ config EMBTK_LIBXEXT_VERSION_1_1_1
+ bool "libXext-1.1.1"
+endchoice
+
+config EMBTK_LIBXEXT_VERSION_STRING
+ string
+ default "1.1.1" if EMBTK_LIBXEXT_VERSION_1_1_1
+
diff --git a/packages/x11/libxext/libxext.mk b/packages/x11/libxext/libxext.mk
new file mode 100644
index 0000000..4eca911
--- /dev/null
+++ b/packages/x11/libxext/libxext.mk
@@ -0,0 +1,101 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file libxext.mk
+# \brief libxext.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+LIBXEXT_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_LIBXEXT_VERSION_STRING)))
+LIBXEXT_SITE := http://xorg.freedesktop.org/archive/individual/lib
+LIBXEXT_PACKAGE := libXext-$(LIBXEXT_VERSION).tar.bz2
+LIBXEXT_BUILD_DIR := $(PACKAGES_BUILD)/libXext-$(LIBXEXT_VERSION)
+
+LIBXEXT_BINS =
+LIBXEXT_SBINS =
+LIBXEXT_INCLUDES = X11/extensions/dpms.h X11/extensions/lbxbuf.h \
+ X11/extensions/lbximage.h X11/extensions/multibuf.h \
+ X11/extensions/shape.h X11/extensions/Xag.h \
+ X11/extensions/Xdbe.h X11/extensions/Xext.h \
+ X11/extensions/XLbx.h X11/extensions/xtestext1.h \
+ X11/extensions/extutil.h X11/extensions/lbxbufstr.h \
+ X11/extensions/MITMisc.h X11/extensions/security.h \
+ X11/extensions/sync.h X11/extensions/Xcup.h \
+ X11/extensions/XEVI.h X11/extensions/Xge.h X11/extensions/XShm.h
+LIBXEXT_LIBS = libXext.*
+LIBXEXT_PKGCONFIGS =
+
+LIBXEXT_DEPS = libx11_install
+
+libxext_install: $(LIBXEXT_BUILD_DIR)/.installed
+
+$(LIBXEXT_BUILD_DIR)/.installed: $(LIBXEXT_DEPS) download_libxext \
+ $(LIBXEXT_BUILD_DIR)/.decompressed $(LIBXEXT_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ libxext-$(LIBXEXT_VERSION) in your root filesystem...")
+ $(call EMBTK_KILL_LT_RPATH,$(LIBXEXT_BUILD_DIR))
+ $(Q)$(MAKE) -C $(LIBXEXT_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(LIBXEXT_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_libxext:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(LIBXEXT_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(LIBXEXT_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(LIBXEXT_PACKAGE) \
+ $(LIBXEXT_SITE)/$(LIBXEXT_PACKAGE)
+
+$(LIBXEXT_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(LIBXEXT_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjf $(DOWNLOAD_DIR)/$(LIBXEXT_PACKAGE)
+ @touch $@
+
+$(LIBXEXT_BUILD_DIR)/.configured:
+ $(Q)cd $(LIBXEXT_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) --libdir=/usr/$(LIBDIR) \
+ --prefix=/usr --enable-malloc0returnsnull
+ @touch $@
+
+libxext_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup libxext-$(LIBXEXT_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(LIBXEXT_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(LIBXEXT_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBXEXT_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBXEXT_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBXEXT_PKGCONFIGS)
+