summaryrefslogtreecommitdiff
path: root/packages/x11/libxext
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-07-02 14:45:48 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-07-02 14:45:48 +0200
commit082dbb99d068e26c577831a1ab26816f39d798b7 (patch)
treecb064d868b650be4b6b3b26d99127221ac651343 /packages/x11/libxext
parent9c40b00ea89c6c0a6cc195e7636da1875052fa02 (diff)
downloadembtoolkit-082dbb99d068e26c577831a1ab26816f39d798b7.tar.gz
embtoolkit-082dbb99d068e26c577831a1ab26816f39d798b7.tar.bz2
embtoolkit-082dbb99d068e26c577831a1ab26816f39d798b7.tar.xz
Embtk generic macros: lower macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/libxext')
-rw-r--r--packages/x11/libxext/libxext.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/packages/x11/libxext/libxext.mk b/packages/x11/libxext/libxext.mk
index 03f042c..1ec522f 100644
--- a/packages/x11/libxext/libxext.mk
+++ b/packages/x11/libxext/libxext.mk
@@ -24,7 +24,7 @@
################################################################################
LIBXEXT_NAME := libXext
-LIBXEXT_VERSION := $(call EMBTK_GET_PKG_VERSION,LIBXEXT)
+LIBXEXT_VERSION := $(call embtk_get_pkgversion,LIBXEXT)
LIBXEXT_SITE := http://xorg.freedesktop.org/archive/individual/lib
LIBXEXT_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
LIBXEXT_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/expat/$(LIBXEXT_VERSION)
@@ -56,7 +56,7 @@ libxext_install:
$(LIBXEXT_BUILD_DIR)/.installed: $(LIBXEXT_DEPS) download_libxext \
$(LIBXEXT_BUILD_DIR)/.decompressed $(LIBXEXT_BUILD_DIR)/.configured
- $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ $(call embtk_generic_message,"Compiling and installing \
libxext-$(LIBXEXT_VERSION) in your root filesystem...")
$(Q)$(MAKE) -C $(LIBXEXT_BUILD_DIR) $(J)
$(Q)$(MAKE) -C $(LIBXEXT_BUILD_DIR) DESTDIR=$(SYSROOT) install
@@ -65,13 +65,13 @@ $(LIBXEXT_BUILD_DIR)/.installed: $(LIBXEXT_DEPS) download_libxext \
@touch $@
download_libxext:
- $(call EMBTK_DOWNLOAD_PKG,LIBXEXT)
+ $(call embtk_download_pkg,LIBXEXT)
$(LIBXEXT_BUILD_DIR)/.decompressed:
- $(call EMBTK_DECOMPRESS_PKG,LIBXEXT)
+ $(call embtk_decompress_pkg,LIBXEXT)
$(LIBXEXT_BUILD_DIR)/.configured:
- $(call EMBTK_CONFIGURE_PKG,LIBXEXT)
+ $(call embtk_configure_pkg,LIBXEXT)
libxext_clean:
- $(call EMBTK_CLEANUP_PKG,LIBXEXT)
+ $(call embtk_cleanup_pkg,LIBXEXT)