summaryrefslogtreecommitdiff
path: root/packages/x11/utilmacros
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:09:24 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:14:30 +0100
commit48b82779acbe28349d2111a86ac2dde95adb59fd (patch)
treece91bf48d1e5e66ed93711f0ecd89be10b45d530 /packages/x11/utilmacros
parentfeb16c4606efa24684e451e4db7d14d9864b5afe (diff)
downloadembtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.gz
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.bz2
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.xz
Packages: X Windowing system: Massive X windowing system packages introduction
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/x11/utilmacros')
-rw-r--r--packages/x11/utilmacros/utilmacros.kconfig42
-rw-r--r--packages/x11/utilmacros/utilmacros.mk101
2 files changed, 143 insertions, 0 deletions
diff --git a/packages/x11/utilmacros/utilmacros.kconfig b/packages/x11/utilmacros/utilmacros.kconfig
new file mode 100644
index 0000000..cc20ca6
--- /dev/null
+++ b/packages/x11/utilmacros/utilmacros.kconfig
@@ -0,0 +1,42 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009-2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file utilmacros.kconfig
+# \brief utilmacros.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+config EMBTK_HAVE_UTILMACROS
+ bool "Have utilmacros"
+ help
+ utilmacros for X windowing system
+choice
+ prompt "utilmacros version you wish"
+ depends on EMBTK_HAVE_UTILMACROS
+ help
+ Here you can choose which version of utilmacros you want to use.
+
+ config EMBTK_UTILMACROS_VERSION_1_6_0
+ bool "utilmacros-1.6.0"
+endchoice
+
+config EMBTK_UTILMACROS_VERSION_STRING
+ string
+ default "1.6.0" if EMBTK_UTILMACROS_VERSION_1_6_0
+
diff --git a/packages/x11/utilmacros/utilmacros.mk b/packages/x11/utilmacros/utilmacros.mk
new file mode 100644
index 0000000..3ca1a50
--- /dev/null
+++ b/packages/x11/utilmacros/utilmacros.mk
@@ -0,0 +1,101 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file utilmacros.mk
+# \brief utilmacros.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+UTILMACROS_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_UTILMACROS_VERSION_STRING)))
+UTILMACROS_SITE := http://xorg.freedesktop.org/archive/individual/util
+UTILMACROS_PACKAGE := util-macros-$(UTILMACROS_VERSION).tar.bz2
+UTILMACROS_BUILD_DIR := $(PACKAGES_BUILD)/util-macros-$(UTILMACROS_VERSION)
+
+UTILMACROS_BINS =
+UTILMACROS_SBINS =
+UTILMACROS_INCLUDES =
+UTILMACROS_LIBS =
+UTILMACROS_PKGCONFIGS = xorg-macros.pc
+
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
+else
+PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
+endif
+
+utilmacros_install: $(UTILMACROS_BUILD_DIR)/.installed
+
+$(UTILMACROS_BUILD_DIR)/.installed: download_utilmacros \
+ $(UTILMACROS_BUILD_DIR)/.decompressed $(UTILMACROS_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ utilmacros-$(UTILMACROS_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(UTILMACROS_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(UTILMACROS_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)cp $(SYSROOT)/usr/share/pkgconfig/xorg-macros.pc $(PKG_CONFIG_PATH)
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_utilmacros:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(UTILMACROS_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(UTILMACROS_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(UTILMACROS_PACKAGE) \
+ $(UTILMACROS_SITE)/$(UTILMACROS_PACKAGE)
+
+$(UTILMACROS_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(UTILMACROS_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(UTILMACROS_PACKAGE)
+ @touch $@
+
+$(UTILMACROS_BUILD_DIR)/.configured:
+ $(Q)cd $(UTILMACROS_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) \
+ --prefix=/usr --libdir=/usr/$(LIBDIR)
+ @touch $@
+
+utilmacros_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup utilmacros-$(UTILMACROS_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(UTILMACROS_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(UTILMACROS_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(UTILMACROS_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(UTILMACROS_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(UTILMACROS_PKGCONFIGS)
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+ $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(UTILMACROS_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(UTILMACROS_PKGCONFIGS)
+endif
+