summaryrefslogtreecommitdiff
path: root/packages/x11/videoproto
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:09:24 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:14:30 +0100
commit48b82779acbe28349d2111a86ac2dde95adb59fd (patch)
treece91bf48d1e5e66ed93711f0ecd89be10b45d530 /packages/x11/videoproto
parentfeb16c4606efa24684e451e4db7d14d9864b5afe (diff)
downloadembtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.gz
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.bz2
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.xz
Packages: X Windowing system: Massive X windowing system packages introduction
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/x11/videoproto')
-rw-r--r--packages/x11/videoproto/videoproto.kconfig42
-rw-r--r--packages/x11/videoproto/videoproto.mk96
2 files changed, 138 insertions, 0 deletions
diff --git a/packages/x11/videoproto/videoproto.kconfig b/packages/x11/videoproto/videoproto.kconfig
new file mode 100644
index 0000000..5712cac
--- /dev/null
+++ b/packages/x11/videoproto/videoproto.kconfig
@@ -0,0 +1,42 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file videoproto.kconfig
+# \brief videoproto.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+config EMBTK_HAVE_VIDEOPROTO
+ bool "Have videoproto"
+ help
+ videoproto for X windowing system
+choice
+ prompt "videoproto version you wish"
+ depends on EMBTK_HAVE_VIDEOPROTO
+ help
+ Here you can choose which version of videoproto you want to use.
+
+ config EMBTK_VIDEOPROTO_VERSION_2_3_0
+ bool "videoproto-2.3.0"
+endchoice
+
+config EMBTK_VIDEOPROTO_VERSION_STRING
+ string
+ default "2.3.0" if EMBTK_VIDEOPROTO_VERSION_2_3_0
+
diff --git a/packages/x11/videoproto/videoproto.mk b/packages/x11/videoproto/videoproto.mk
new file mode 100644
index 0000000..3597a7c
--- /dev/null
+++ b/packages/x11/videoproto/videoproto.mk
@@ -0,0 +1,96 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file videoproto.mk
+# \brief videoproto.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+VIDEOPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_VIDEOPROTO_VERSION_STRING)))
+VIDEOPROTO_SITE := http://ftp.x.org/pub/individual/proto
+VIDEOPROTO_PACKAGE := videoproto-$(VIDEOPROTO_VERSION).tar.bz2
+VIDEOPROTO_BUILD_DIR := $(PACKAGES_BUILD)/videoproto-$(VIDEOPROTO_VERSION)
+
+VIDEOPROTO_BINS =
+VIDEOPROTO_SBINS =
+VIDEOPROTO_INCLUDES = X11/extensions/vldXvMC.h X11/extensions/Xv.h \
+ X11/extensions/XvMC.h X11/extensions/XvMCproto.h \
+ X11/extensions/Xvproto.h
+VIDEOPROTO_LIBS =
+VIDEOPROTO_PKGCONFIGS = videoproto.pc
+
+videoproto_install: $(VIDEOPROTO_BUILD_DIR)/.installed
+
+$(VIDEOPROTO_BUILD_DIR)/.installed: download_videoproto \
+ $(VIDEOPROTO_BUILD_DIR)/.decompressed $(VIDEOPROTO_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ videoproto-$(VIDEOPROTO_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(VIDEOPROTO_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(VIDEOPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_videoproto:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(VIDEOPROTO_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(VIDEOPROTO_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(VIDEOPROTO_PACKAGE) \
+ $(VIDEOPROTO_SITE)/$(VIDEOPROTO_PACKAGE)
+
+$(VIDEOPROTO_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(VIDEOPROTO_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(VIDEOPROTO_PACKAGE)
+ @touch $@
+
+$(VIDEOPROTO_BUILD_DIR)/.configured:
+ $(Q)cd $(VIDEOPROTO_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) --libdir=/usr/$(LIBDIR) \
+ --prefix=/usr
+ @touch $@
+
+videoproto_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup videoproto-$(VIDEOPROTO_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(VIDEOPROTO_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(VIDEOPROTO_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(VIDEOPROTO_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(VIDEOPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(VIDEOPROTO_PKGCONFIGS)
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+ $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(VIDEOPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(VIDEOPROTO_PKGCONFIGS)
+endif
+