summaryrefslogtreecommitdiff
path: root/packages/x11/xcbproto
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-07-02 14:45:48 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-07-02 14:45:48 +0200
commit082dbb99d068e26c577831a1ab26816f39d798b7 (patch)
treecb064d868b650be4b6b3b26d99127221ac651343 /packages/x11/xcbproto
parent9c40b00ea89c6c0a6cc195e7636da1875052fa02 (diff)
downloadembtoolkit-082dbb99d068e26c577831a1ab26816f39d798b7.tar.gz
embtoolkit-082dbb99d068e26c577831a1ab26816f39d798b7.tar.bz2
embtoolkit-082dbb99d068e26c577831a1ab26816f39d798b7.tar.xz
Embtk generic macros: lower macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/xcbproto')
-rw-r--r--packages/x11/xcbproto/xcbproto.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/x11/xcbproto/xcbproto.mk b/packages/x11/xcbproto/xcbproto.mk
index cc08f1d..646895a 100644
--- a/packages/x11/xcbproto/xcbproto.mk
+++ b/packages/x11/xcbproto/xcbproto.mk
@@ -39,7 +39,7 @@ xcbproto_install:
$(XCBPROTO_BUILD_DIR)/.installed: download_xcbproto \
$(XCBPROTO_BUILD_DIR)/.decompressed $(XCBPROTO_BUILD_DIR)/.configured
- $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ $(call embtk_generic_message,"Compiling and installing \
xcbproto-$(XCBPROTO_VERSION) in your root filesystem...")
$(Q)$(MAKE) -C $(XCBPROTO_BUILD_DIR) $(J)
$(Q)$(MAKE) -C $(XCBPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
@@ -48,14 +48,14 @@ $(XCBPROTO_BUILD_DIR)/.installed: download_xcbproto \
@touch $@
download_xcbproto:
- $(call EMBTK_GENERIC_MESSAGE,"Downloading $(XCBPROTO_PACKAGE) \
+ $(call embtk_generic_message,"Downloading $(XCBPROTO_PACKAGE) \
if necessary...")
@test -e $(DOWNLOAD_DIR)/$(XCBPROTO_PACKAGE) || \
wget -O $(DOWNLOAD_DIR)/$(XCBPROTO_PACKAGE) \
$(XCBPROTO_SITE)/$(XCBPROTO_PACKAGE)
$(XCBPROTO_BUILD_DIR)/.decompressed:
- $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(XCBPROTO_PACKAGE) ...")
+ $(call embtk_generic_message,"Decompressing $(XCBPROTO_PACKAGE) ...")
@tar -C $(PACKAGES_BUILD) -xzf $(DOWNLOAD_DIR)/$(XCBPROTO_PACKAGE)
@touch $@
@@ -83,7 +83,7 @@ $(XCBPROTO_BUILD_DIR)/.configured:
@touch $@
xcbproto_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup xcbproto-$(XCBPROTO_VERSION)...")
+ $(call embtk_generic_message,"cleanup xcbproto-$(XCBPROTO_VERSION)...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(XCBPROTO_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(XCBPROTO_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(XCBPROTO_INCLUDES)