summaryrefslogtreecommitdiff
path: root/packages/x11/xkeyboardconfig/xkeyboardconfig.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/x11/xkeyboardconfig/xkeyboardconfig.mk
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/xkeyboardconfig/xkeyboardconfig.mk')
-rw-r--r--packages/x11/xkeyboardconfig/xkeyboardconfig.mk42
1 files changed, 26 insertions, 16 deletions
diff --git a/packages/x11/xkeyboardconfig/xkeyboardconfig.mk b/packages/x11/xkeyboardconfig/xkeyboardconfig.mk
index fbba20d..a612aa4 100644
--- a/packages/x11/xkeyboardconfig/xkeyboardconfig.mk
+++ b/packages/x11/xkeyboardconfig/xkeyboardconfig.mk
@@ -1,24 +1,25 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file xkeyboardconfig.mk
# \brief xkeyboardconfig.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date March 2010
################################################################################
@@ -35,7 +36,10 @@ XKEYBOARDCONFIG_PKGCONFIGS =
XKEYBOARDCONFIG_DEPS = xkbcomp_install
-xkeyboardconfig_install: $(XKEYBOARDCONFIG_BUILD_DIR)/.installed
+xkeyboardconfig_install:
+ @test -e $(XKEYBOARDCONFIG_BUILD_DIR)/.installed || \
+ $(MAKE) $(XKEYBOARDCONFIG_BUILD_DIR)/.installed
+ $(MAKE) $(XKEYBOARDCONFIG_BUILD_DIR)/.special
$(XKEYBOARDCONFIG_BUILD_DIR)/.installed: $(XKEYBOARDCONFIG_DEPS) \
download_xkeyboardconfig $(XKEYBOARDCONFIG_BUILD_DIR)/.decompressed \
@@ -46,8 +50,6 @@ $(XKEYBOARDCONFIG_BUILD_DIR)/.installed: $(XKEYBOARDCONFIG_DEPS) \
$(Q)$(MAKE) -C $(XKEYBOARDCONFIG_BUILD_DIR) DESTDIR=$(SYSROOT) install
$(Q)$(MAKE) libtool_files_adapt
$(Q)$(MAKE) pkgconfig_files_adapt
- $(Q)-mkdir -p $(ROOTFS)/usr/share/X11
- $(Q)-cp -R $(SYSROOT)/usr/share/X11/xkb $(ROOTFS)/usr/share/X11/
@touch $@
download_xkeyboardconfig:
@@ -86,10 +88,18 @@ $(XKEYBOARDCONFIG_BUILD_DIR)/.configured:
@touch $@
xkeyboardconfig_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup xkeyboardconfig-$(XKEYBOARDCONFIG_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup xkeyboardconfig...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(XKEYBOARDCONFIG_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(XKEYBOARDCONFIG_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(XKEYBOARDCONFIG_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(XKEYBOARDCONFIG_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(XKEYBOARDCONFIG_PKGCONFIGS)
+ $(Q)-rm -rf $(XKEYBOARDCONFIG_BUILD_DIR)
+
+.PHONY: $(XKEYBOARDCONFIG_BUILD_DIR)/.special
+$(XKEYBOARDCONFIG_BUILD_DIR)/.special:
+ $(Q)-mkdir -p $(ROOTFS)/usr/share
+ $(Q)-mkdir -p $(ROOTFS)/usr/share/X11
+ $(Q)-cp -R $(SYSROOT)/usr/share/X11/xkb $(ROOTFS)/usr/share/X11/
+ @touch $@