summaryrefslogtreecommitdiff
path: root/packages/x11
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-01-30 17:29:38 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-01-30 17:29:38 +0100
commitcb7b6ccb98839589d834e263ffe68b9653ae291a (patch)
treeeb2a980d8b4f32f3f066894daf3b2405423195b4 /packages/x11
parent43b7d3e640e203ff3c9d8fa769d1ffb2d34bd7b9 (diff)
downloadembtoolkit-cb7b6ccb98839589d834e263ffe68b9653ae291a.tar.gz
embtoolkit-cb7b6ccb98839589d834e263ffe68b9653ae291a.tar.bz2
embtoolkit-cb7b6ccb98839589d834e263ffe68b9653ae291a.tar.xz
Packages: X11/libx11: add libX11 and convert it to use generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11')
-rw-r--r--packages/x11/libx11/libx11.kconfig37
-rw-r--r--packages/x11/libx11/libx11.mk49
2 files changed, 36 insertions, 50 deletions
diff --git a/packages/x11/libx11/libx11.kconfig b/packages/x11/libx11/libx11.kconfig
index cf41de8..d1d822a 100644
--- a/packages/x11/libx11/libx11.kconfig
+++ b/packages/x11/libx11/libx11.kconfig
@@ -1,19 +1,20 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file libx11.kconfig
@@ -24,6 +25,7 @@
config EMBTK_HAVE_LIBX11
bool "Have libX11"
+ select EMBTK_LIBX11_PKG_IS_TARBZ2
select EMBTK_HAVE_UTILMACROS
select EMBTK_HAVE_INPUTPROTO
select EMBTK_HAVE_KBPROTO
@@ -32,13 +34,15 @@ config EMBTK_HAVE_LIBX11
select EMBTK_HAVE_LIBXCB
select EMBTK_HAVE_XTRANS
help
- libX11 for X windowing system
+ libX11 for X windowing system.
choice
prompt "libx11 version you wish"
depends on EMBTK_HAVE_LIBX11
help
Here you can choose which version of libx11 you want to use.
+ config EMBTK_LIBX11_VERSION_1_4_1
+ bool "libX11-1.4.1"
config EMBTK_LIBX11_VERSION_1_3_6
bool "libX11-1.3.6"
config EMBTK_LIBX11_VERSION_1_3_5
@@ -51,8 +55,17 @@ endchoice
config EMBTK_LIBX11_VERSION_STRING
string
+ default "1.4.1" if EMBTK_LIBX11_VERSION_1_4_1
default "1.3.6" if EMBTK_LIBX11_VERSION_1_3_6
default "1.3.5" if EMBTK_LIBX11_VERSION_1_3_5
default "1.3.4" if EMBTK_LIBX11_VERSION_1_3_4
default "1.3.3" if EMBTK_LIBX11_VERSION_1_3_3
+config EMBTK_LIBX11_NEED_PATCH
+ bool
+config EMBTK_LIBX11_NEED_AUTORECONF
+ bool
+config EMBTK_LIBX11_PKG_IS_TARGZ
+ bool
+config EMBTK_LIBX11_PKG_IS_TARBZ2
+ bool
diff --git a/packages/x11/libx11/libx11.mk b/packages/x11/libx11/libx11.mk
index 16356eb..72d396d 100644
--- a/packages/x11/libx11/libx11.mk
+++ b/packages/x11/libx11/libx11.mk
@@ -23,9 +23,12 @@
# \date March 2010
################################################################################
-LIBX11_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_LIBX11_VERSION_STRING)))
+LIBX11_NAME := libX11
+LIBX11_VERSION := $(call EMBTK_GET_PKG_VERSION,LIBX11)
LIBX11_SITE := http://xorg.freedesktop.org/archive/individual/lib
+LIBX11_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
LIBX11_PACKAGE := libX11-$(LIBX11_VERSION).tar.bz2
+LIBX11_SRC_DIR := $(PACKAGES_BUILD)/libX11-$(LIBX11_VERSION)
LIBX11_BUILD_DIR := $(PACKAGES_BUILD)/libX11-$(LIBX11_VERSION)
LIBX11_BINS =
@@ -36,6 +39,9 @@ LIBX11_INCLUDES = X11/cursorfont.h X11/ImUtil.h X11/Xcms.h X11/XKBlib.h \
LIBX11_LIBS = libX11* X11/Xcms.txt
LIBX11_PKGCONFIGS = x11.pc x11-xcb.pc
+LIBX11_CONFIGURE_OPTS := --with-xcb --without-xmlto --without-ps2pdf \
+ --without-groff --disable-malloc0returnsnull
+
LIBX11_DEPS = utilmacros_install inputproto_install kbproto_install \
xextproto_install xproto_install libxcb_install xtrans_install
@@ -48,7 +54,6 @@ $(LIBX11_BUILD_DIR)/.installed: $(LIBX11_DEPS) download_libx11 \
$(LIBX11_BUILD_DIR)/.decompressed $(LIBX11_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
libx11-$(LIBX11_VERSION) in your root filesystem...")
- $(call EMBTK_KILL_LT_RPATH,$(LIBX11_BUILD_DIR))
@cd $(LIBX11_BUILD_DIR)/src/util; \
gcc makekeys.c -c -o makekeys-makekeys.o; gcc makekeys.c -o makekeys
$(Q)$(MAKE) -C $(LIBX11_BUILD_DIR) $(J)
@@ -59,48 +64,16 @@ $(LIBX11_BUILD_DIR)/.installed: $(LIBX11_DEPS) download_libx11 \
@touch $@
download_libx11:
- $(call EMBTK_GENERIC_MESSAGE,"Downloading $(LIBX11_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(LIBX11_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(LIBX11_PACKAGE) \
- $(LIBX11_SITE)/$(LIBX11_PACKAGE)
+ $(call EMBTK_DOWNLOAD_PKG,LIBX11)
$(LIBX11_BUILD_DIR)/.decompressed:
- $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(LIBX11_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(LIBX11_PACKAGE)
- @touch $@
+ $(call EMBTK_DECOMPRESS_PKG,LIBX11)
$(LIBX11_BUILD_DIR)/.configured:
- $(Q)cd $(LIBX11_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLGAS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --prefix=/usr --libdir=/usr/$(LIBDIR) \
- --with-xcb --disable-malloc0returnsnull
- @touch $@
+ $(call EMBTK_CONFIGURE_PKG,LIBX11)
libx11_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup libx11-$(LIBX11_VERSION)...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(LIBX11_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(LIBX11_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBX11_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBX11_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBX11_PKGCONFIGS)
- $(Q)-rm -rf $(LIBX11_BUILD_DIR)*
+ $(call EMBTK_CLEANUP_PKG,LIBX11)
$(LIBX11_BUILD_DIR)/.patchlibtool:
@LIBX11_LT_FILES=`find $(SYSROOT)/usr/$(LIBDIR)/libX11-* -type f -name *.la`; \