summaryrefslogtreecommitdiff
path: root/packages/graphics/graphics.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/graphics/graphics.mk')
-rw-r--r--packages/graphics/graphics.mk12
1 files changed, 0 insertions, 12 deletions
diff --git a/packages/graphics/graphics.mk b/packages/graphics/graphics.mk
index 0149441..e2bdc0b 100644
--- a/packages/graphics/graphics.mk
+++ b/packages/graphics/graphics.mk
@@ -25,61 +25,49 @@
#atk
include $(EMBTK_ROOT)/packages/graphics/atk/atk.mk
-ROOTFS_COMPONENTS_CLEAN += atk_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_ATK) += atk_install
#Cairo
include $(EMBTK_ROOT)/packages/graphics/cairo/cairo.mk
-ROOTFS_COMPONENTS_CLEAN += cairo_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_CAIRO) += cairo_install
#DirectFB
include $(EMBTK_ROOT)/packages/graphics/directfb/directfb.mk
-ROOTFS_COMPONENTS_CLEAN += directfb_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_DIRECTFB) += directfb_install
#fontconfig
include $(EMBTK_ROOT)/packages/graphics/fontconfig/fontconfig.mk
-ROOTFS_COMPONENTS_CLEAN += fontconfig_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FONTCONFIG) += fontconfig_install
#FreeFont
include $(EMBTK_ROOT)/packages/graphics/freefont/freefont.mk
-ROOTFS_COMPONENTS_CLEAN += ttmkfdir_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FREEFONT_TTF) += freefont_ttf_install
#FreeType
include $(EMBTK_ROOT)/packages/graphics/freetype/freetype.mk
-ROOTFS_COMPONENTS_CLEAN += freetype_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FREETYPE) += freetype_install
#gtk+
include $(EMBTK_ROOT)/packages/graphics/gtk/gtk.mk
-ROOTFS_COMPONENTS_CLEAN += gtk_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GTK) += gtk_install
#imlib2
include $(EMBTK_ROOT)/packages/graphics/imlib2/imlib2.mk
-ROOTFS_COMPONENTS_CLEAN += imlib2_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_IMLIB2) += imlib2_install
#libjpeg
include $(EMBTK_ROOT)/packages/graphics/libjpeg/libjpeg.mk
-ROOTFS_COMPONENTS_CLEAN += libjpeg_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBJPEG) += libjpeg_install
#libpng
include $(EMBTK_ROOT)/packages/graphics/libpng/libpng.mk
-ROOTFS_COMPONENTS_CLEAN += libpng_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBPNG) += libpng_install
#libtiff
include $(EMBTK_ROOT)/packages/graphics/libtiff/libtiff.mk
-ROOTFS_COMPONENTS_CLEAN += libtiff_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBTIFF) += libtiff_install
#pixman
include $(EMBTK_ROOT)/packages/graphics/pixman/pixman.mk
-ROOTFS_COMPONENTS_CLEAN += pixman_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_PIXMAN) += pixman_install