summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/hosttools-buildopts.kconfig10
-rw-r--r--packages/htools/hosttools-buildopts.mk3
-rw-r--r--packages/htools/zlib/zlib.kconfig38
-rw-r--r--packages/htools/zlib/zlib.mk55
4 files changed, 101 insertions, 5 deletions
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index b4bb986..1f7eced 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -75,11 +75,6 @@ config EMBTK_HAVE_MKIMAGE
u-boot mkimage tool.
#
-# zlib for host
-#
-source kconfig/zlib_host.kconfig
-
-#
# gperf for host
#
source kconfig/gperf_host.kconfig
@@ -146,3 +141,8 @@ source kconfig/gperf_host.kconfig
# libelf
#
source packages/misc/libelf/libelf.kconfig
+
+#
+# zlib for host
+#
+source packages/htools/zlib/zlib.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index 5cbeb29..56df4f5 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -35,3 +35,6 @@ $(call embtk_include_hostpkg,fakeroot_host)
# pkgconf
include packages/htools/pkgconf/vars.mk
$(call embtk_include_hostpkg,pkgconf_host)
+
+# zlib
+$(call embtk_include_hostpkg,zlib_host)
diff --git a/packages/htools/zlib/zlib.kconfig b/packages/htools/zlib/zlib.kconfig
new file mode 100644
index 0000000..75a73e9
--- /dev/null
+++ b/packages/htools/zlib/zlib.kconfig
@@ -0,0 +1,38 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file zlib_host.kconfig
+# \brief zlib_host.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date August 2010
+################################################################################
+
+config EMBTK_HOST_HAVE_ZLIB
+ bool
+ help
+ zlib is a compression library.
+
+config EMBTK_ZLIB_HOST_VERSION_STRING
+ string
+ default "1.2.5"
+
+config EMBTK_ZLIB_HOST_NEED_PATCH
+ bool
+config EMBTK_ZLIB_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/zlib/zlib.mk b/packages/htools/zlib/zlib.mk
new file mode 100644
index 0000000..79fa28c
--- /dev/null
+++ b/packages/htools/zlib/zlib.mk
@@ -0,0 +1,55 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file zlib_host.mk
+# \brief zlib_host.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2009
+################################################################################
+
+ZLIB_HOST_NAME := zlib
+ZLIB_HOST_VERSION := $(call embtk_get_pkgversion,zlib_host)
+ZLIB_HOST_SITE := http://zlib.net
+ZLIB_HOST_PACKAGE := zlib-$(ZLIB_HOST_VERSION).tar.bz2
+ZLIB_HOST_SRC_DIR := $(embtk_toolsb)/zlib-$(ZLIB_HOST_VERSION)
+ZLIB_HOST_BUILD_DIR := $(embtk_toolsb)/zlib-$(ZLIB_HOST_VERSION)
+
+ZLIB_HOST_CONFIGURE_ENV := CC=$(HOSTCC_CACHED)
+
+define embtk_install_zlib_host
+ $(call embtk_makeinstall_hostpkg,zlib_host)
+endef
+
+define embtk_configure_zlib_host
+ $(Q)cd $(ZLIB_HOST_BUILD_DIR); \
+ CPPFLAGS="-I$(embtk_htools)/usr/include" \
+ LDFLAGS="-L$(embtk_htools)/$(LIBDIR) -L$(embtk_htools)/usr/$(LIBDIR)" \
+ $(ZLIB_HOST_CONFIGURE_ENV) \
+ $(CONFIG_EMBTK_SHELL) $(ZLIB_HOST_SRC_DIR)/configure \
+ --prefix=$(embtk_htools)/usr $(ZLIB_HOST_CONFIGURE_OPTS)
+ $(call __embtk_setconfigured_pkg,zlib_host)
+endef
+
+define embtk_beforeinstall_zlib_host
+ $(embtk_configure_zlib_host)
+endef
+
+define embtk_cleanup_zlib_host
+ $(call embtk_pinfo,"Clean up zlib for host")
+endef