summaryrefslogtreecommitdiff
path: root/packages/system/e2fsprogs/e2fsprogs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/system/e2fsprogs/e2fsprogs.mk')
-rw-r--r--packages/system/e2fsprogs/e2fsprogs.mk83
1 files changed, 83 insertions, 0 deletions
diff --git a/packages/system/e2fsprogs/e2fsprogs.mk b/packages/system/e2fsprogs/e2fsprogs.mk
new file mode 100644
index 0000000..ae0eaab
--- /dev/null
+++ b/packages/system/e2fsprogs/e2fsprogs.mk
@@ -0,0 +1,83 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file e2fsprogs.mk
+# \brief e2fsprogs.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2011
+################################################################################
+
+E2FSPROGS_NAME := e2fsprogs
+E2FSPROGS_VERSION := $(call EMBTK_GET_PKG_VERSION,E2FSPROGS)
+E2FSPROGS_SITE := http://sourceforge.net/projects/e2fsprogs/files/e2fsprogs/$(E2FSPROGS_VERSION)
+E2FSPROGS_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+E2FSPROGS_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/e2fsprogs/$(E2FSPROGS_VERSION)
+E2FSPROGS_PACKAGE := e2fsprogs-$(E2FSPROGS_VERSION).tar.gz
+E2FSPROGS_SRC_DIR := $(PACKAGES_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
+E2FSPROGS_BUILD_DIR := $(PACKAGES_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
+
+E2FSPROGS_BINS :=
+E2FSPROGS_SBINS :=
+E2FSPROGS_INCLUDES := uuid
+E2FSPROGS_LIBS := libuuid.*
+E2FSPROGS_LIBEXECS :=
+E2FSPROGS_PKGCONFIGS := uuid.pc
+
+E2FSPROGS_CONFIGURE_ENV :=
+E2FSPROGS_MAKE_OPTS := LDCONFIG=true
+E2FSPROGS_MAKE_DIRS := lib/uuid
+E2FSPROGS_CONFIGURE_OPTS := --disable-compression --disable-htree \
+ --enable-elf-shlibs --disable-bsd-shlibs \
+ --disable-profile --disable-checker --disable-jbd-debug \
+ --disable-blkid-debug --disable-testio-debug \
+ --enable-libuuid --enable-libblkid --disable-debugfs \
+ --disable-imager --disable-resizer --disable-fsck \
+ --disable-e2initrd-helper --disable-tls --disable-tls \
+ --disable-nls --disable-rpath --with-included-gettext
+
+e2fsprogs_install:
+ $(call EMBTK_INSTALL_PKG,E2FSPROGS)
+
+download_e2fsprogs:
+ $(call EMBTK_DOWNLOAD_PKG,E2FSPROGS)
+
+e2fsprogs_clean:
+ $(call EMBTK_CLEANUP_PKG,E2FSPROGS)
+
+#
+# E2FSPROGS for host development machine
+#
+E2FSPROGS_HOST_NAME := $(E2FSPROGS_NAME)
+E2FSPROGS_HOST_VERSION := $(E2FSPROGS_VERSION)
+E2FSPROGS_HOST_SITE := $(E2FSPROGS_SITE)
+E2FSPROGS_HOST_SITE_MIRROR3 := $(E2FSPROGS_SITE_MIRROR3)
+E2FSPROGS_HOST_PATCH_SITE := $(E2FSPROGS_PATCH_SITE)
+E2FSPROGS_HOST_PACKAGE := $(E2FSPROGS_PACKAGE)
+E2FSPROGS_HOST_SRC_DIR := $(TOOLS_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
+E2FSPROGS_HOST_BUILD_DIR := $(TOOLS_BUILD)/e2fsprogs-$(E2FSPROGS_VERSION)
+
+E2FSPROGS_HOST_MAKE_OPTS := LDCONFIG=true
+
+e2fsprogs_host_install:
+ $(call EMBTK_INSTALL_HOSTPKG,E2FSPROGS_HOST)
+
+download_e2fsprogs_host:
+ $(call EMBTK_DOWNLOAD_PKG,E2FSPROGS_HOST)
+
+e2fsprogs_host_clean: