summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefanus Du Toit <stefanus.dutoit@rapidmind.com>2009-06-08 21:18:31 +0000
committerStefanus Du Toit <stefanus.dutoit@rapidmind.com>2009-06-08 21:18:31 +0000
commit4ba3a0ec6c43ea4110c91b29a0925828df0f1643 (patch)
tree4673ca3cbcb5d70b6cddeda1e97d4ca4f627fbc9 /CMakeLists.txt
parenta7b0ded2a26003d91db6c58d6ad945a39f70585c (diff)
downloadllvm-4ba3a0ec6c43ea4110c91b29a0925828df0f1643.tar.gz
llvm-4ba3a0ec6c43ea4110c91b29a0925828df0f1643.tar.bz2
llvm-4ba3a0ec6c43ea4110c91b29a0925828df0f1643.tar.xz
Allow setting the C runtime to be used with MSVC from cmake.
Patch by Tareq Siraj. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@73084 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81333987be..6c2c16bdd2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,11 +186,26 @@ if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )
endif( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )
if( MSVC )
+ # List of valid CRTs for MSVC
+ set(MSVC_CRT
+ MD
+ MDd)
+
+ set(LLVM_USE_CRT "" CACHE STRING "Specify VC++ CRT to use for debug/release configurations.")
add_llvm_definitions( -D_CRT_SECURE_NO_DEPRECATE -D_CRT_SECURE_NO_WARNINGS )
add_llvm_definitions( -D_SCL_SECURE_NO_WARNINGS -DCRT_NONSTDC_NO_WARNINGS )
add_llvm_definitions( -D_SCL_SECURE_NO_DEPRECATE )
add_llvm_definitions( -wd4146 -wd4503 -wd4996 -wd4800 -wd4244 -wd4624 )
add_llvm_definitions( -wd4355 -wd4715 -wd4180 -wd4345 -wd4224 )
+
+ if (NOT ${LLVM_USE_CRT} STREQUAL "")
+ list(FIND MSVC_CRT ${LLVM_USE_CRT} idx)
+ if (idx LESS 0)
+ message(FATAL_ERROR "Invalid value for LLVM_USE_CRT: ${LLVM_USE_CRT}. Valid options are one of: ${MSVC_CRT}")
+ endif (idx LESS 0)
+ add_llvm_definitions("/${LLVM_USE_CRT}")
+ message(STATUS "Using VC++ CRT: ${LLVM_USE_CRT}")
+ endif (NOT ${LLVM_USE_CRT} STREQUAL "")
endif( MSVC )
include_directories( ${LLVM_BINARY_DIR}/include ${LLVM_MAIN_INCLUDE_DIR})