summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVictor Oliveira <Victor.Oliveira@amd.com>2012-08-09 01:13:59 +0000
committerVictor Oliveira <Victor.Oliveira@amd.com>2012-08-09 01:13:59 +0000
commit0e80e182a9401e6ae82df30ae93ef4b4585082f0 (patch)
tree13f220528e70b57b986bc90a37f7bfabfb227241 /CMakeLists.txt
parent9bac67657bb158d8649e85494f5999993591b87c (diff)
downloadllvm-0e80e182a9401e6ae82df30ae93ef4b4585082f0.tar.gz
llvm-0e80e182a9401e6ae82df30ae93ef4b4585082f0.tar.bz2
llvm-0e80e182a9401e6ae82df30ae93ef4b4585082f0.tar.xz
Support for experimental targets
Added LLVM_EXPERIMENTAL_TARGETS_TO_BUILD in CMake and --enable-experimental-targets in configure. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@161561 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed230aee5b..7b5240c795 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,6 +99,9 @@ else( MSVC )
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
endif( MSVC )
+set(LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ""
+ CACHE STRING "Semicolon-separated list of experimental targets to build.")
+
option(BUILD_SHARED_LIBS
"Build all libraries as shared libraries instead of static" OFF)
@@ -136,6 +139,11 @@ foreach(c ${LLVM_TARGETS_TO_BUILD})
endif()
endforeach(c)
+set(LLVM_TARGETS_TO_BUILD
+ ${LLVM_TARGETS_TO_BUILD}
+ ${LLVM_EXPERIMENTAL_TARGETS_TO_BUILD}
+ )
+
set(llvm_builded_incs_dir ${LLVM_BINARY_DIR}/include/llvm)
include(AddLLVMDefinitions)