summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-07-17 17:35:15 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-07-17 17:35:15 +0000
commit2341a3c3318cf0d2cceadd8fa9b7b543b6e4f2d5 (patch)
tree5ad6f35811c98bc1416c56678bfe12257c0eb27c /CMakeLists.txt
parent3e19473af308325801fbdd27abc56c8afcfde2cb (diff)
downloadllvm-2341a3c3318cf0d2cceadd8fa9b7b543b6e4f2d5.tar.gz
llvm-2341a3c3318cf0d2cceadd8fa9b7b543b6e4f2d5.tar.bz2
llvm-2341a3c3318cf0d2cceadd8fa9b7b543b6e4f2d5.tar.xz
Fix CMake build on Solaris
When building LLVM/Clang on Solaris. The generated makefiles would have an extraneous semi-colon character in them prior to this change due to the way the 'CMAKE_CXX_FLAGS' variable was defined. Simply adjusting the definition by moving the current CMAKE_CXX_FLAGS value within the quotes solves the problem. Patch by Art Haas! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@135361 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0404cf4b8..1809aecc00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -181,7 +181,7 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
include_directories( ${LLVM_BINARY_DIR}/include ${LLVM_MAIN_INCLUDE_DIR})
if( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
- SET(CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-include llvm/Support/Solaris.h")
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -include llvm/Support/Solaris.h")
endif( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
include(AddLLVM)