summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2013-04-04 01:01:32 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2013-04-04 01:01:32 +0000
commit436633e2a281ff620f2f4d9a06b33d3a99924717 (patch)
tree667d1785d2db75b65efa3458428c90af5d022513 /CMakeLists.txt
parente3d75ee2a1c8ea11fd01fc49055d08f2da7f5668 (diff)
downloadllvm-436633e2a281ff620f2f4d9a06b33d3a99924717.tar.gz
llvm-436633e2a281ff620f2f4d9a06b33d3a99924717.tar.bz2
llvm-436633e2a281ff620f2f4d9a06b33d3a99924717.tar.xz
Don't export symbols in every binary on linux.
On freebsd this makes sure that symbols are exported on the binaries that need them. The net result is that we should get symbols in the binaries that need them on every platform. On linux x86-64 this reduces the size of the bin directory from 262MB to 250MB. Patch by Stephen Checkoway. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@178725 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 80c95a08bc..95ea3115d3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -390,6 +390,10 @@ if( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -include llvm/Support/Solaris.h")
endif( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
+# Make sure we don't get -rdynamic in every binary. For those that need it,
+# use set_target_properties(target PROPERTIES ENABLE_EXPORTS 1)
+set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS "")
+
include(AddLLVM)
include(TableGen)