summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Gottesman <mgottesman@apple.com>2013-08-24 07:25:21 +0000
committerMichael Gottesman <mgottesman@apple.com>2013-08-24 07:25:21 +0000
commit5b83d0c092776732d60c5964876c16993a6213b6 (patch)
treec6ed5b139cca446e63cdfebc9ab4b9b6742282d0 /CMakeLists.txt
parent4a48389b27cafe30a38592b50e0f4b9e97b9d65e (diff)
downloadllvm-5b83d0c092776732d60c5964876c16993a6213b6.tar.gz
llvm-5b83d0c092776732d60c5964876c16993a6213b6.tar.bz2
llvm-5b83d0c092776732d60c5964876c16993a6213b6.tar.xz
[autotools->cmake] Enable generation of doxygen documentation via cmake.
I am going to add in a subsequent patch support for generating the llvm manpage. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@189164 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b5cc73188..3e56a3c036 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -231,6 +231,10 @@ option(LLVM_BUILD_TESTS
"Build LLVM unit tests. If OFF, just generate build targets." OFF)
option(LLVM_INCLUDE_TESTS "Generate build targets for the LLVM unit tests." ON)
+option (LLVM_BUILD_DOCS "Build the llvm documentation." OFF)
+option (LLVM_INCLUDE_DOCS "Generate build targets for llvm documentation." ON)
+option (LLVM_ENABLE_DOXYGEN "Use doxygen to generate llvm documentation." OFF)
+
# All options referred to from HandleLLVMOptions have to be specified
# BEFORE this include, otherwise options will not be correctly set on
# first cmake run
@@ -465,6 +469,10 @@ if( LLVM_INCLUDE_TESTS )
)
endif()
+if (LLVM_INCLUDE_DOCS)
+ add_subdirectory(docs)
+endif()
+
add_subdirectory(cmake/modules)
if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
@@ -497,8 +505,6 @@ if( NOT WIN32 )
endif()
-# TODO: make and install documentation.
-
set(CPACK_PACKAGE_VENDOR "LLVM")
set(CPACK_PACKAGE_VERSION_MAJOR ${LLVM_VERSION_MAJOR})
set(CPACK_PACKAGE_VERSION_MINOR ${LLVM_VERSION_MINOR})