summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Northover <Tim.Northover@arm.com>2013-04-15 11:53:05 +0000
committerTim Northover <Tim.Northover@arm.com>2013-04-15 11:53:05 +0000
commiteaa752f5e1c10fc7fdbfb7f497a75c623677cb1e (patch)
treefcb8667557f0d7f7d2c798d661c736d9a3af8978 /CMakeLists.txt
parent60d20a81fcf91818db6b52520dd2ce520ad57a42 (diff)
downloadllvm-eaa752f5e1c10fc7fdbfb7f497a75c623677cb1e.tar.gz
llvm-eaa752f5e1c10fc7fdbfb7f497a75c623677cb1e.tar.bz2
llvm-eaa752f5e1c10fc7fdbfb7f497a75c623677cb1e.tar.xz
Enable all targets by default on Visual Studio.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@179518 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d216924b1..c8c3038eba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,13 +91,8 @@ set(LLVM_ALL_TARGETS
# List of targets with JIT support:
set(LLVM_TARGETS_WITH_JIT X86 PowerPC ARM Mips)
-if( MSVC )
- set(LLVM_TARGETS_TO_BUILD X86
- CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
-else( MSVC )
- set(LLVM_TARGETS_TO_BUILD "all"
+set(LLVM_TARGETS_TO_BUILD "all"
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
-endif( MSVC )
set(LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ""
CACHE STRING "Semicolon-separated list of experimental targets to build.")