summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-08-28 01:19:26 +0000
committerHans Wennborg <hans@hanshq.net>2013-08-28 01:19:26 +0000
commit110b5209d92f224050f2755539bda8f1d801f94b (patch)
tree1abf79efaf3ce8f49140abf72c11c48b7a21c0e1 /CMakeLists.txt
parent7f9a887d3f64d1227b911c9180767d95dbba4c10 (diff)
downloadllvm-110b5209d92f224050f2755539bda8f1d801f94b.tar.gz
llvm-110b5209d92f224050f2755539bda8f1d801f94b.tar.bz2
llvm-110b5209d92f224050f2755539bda8f1d801f94b.tar.xz
cmake: Add msbuild integration to the install
This adds the msbuild integration files to the install, provides batch scripts for (un)installing it in a convenient way, and hooks up the nsis installer to run those scripts. Differential Revision: http://llvm-reviews.chandlerc.com/D1537 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@189434 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d38fe5d8a..56adcf335d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -512,6 +512,11 @@ set(CPACK_RESOURCE_FILE_LICENSE "${LLVM_MAIN_SRC_DIR}/LICENSE.TXT")
if(WIN32 AND NOT UNIX)
set(CPACK_PACKAGE_ICON "${LLVM_MAIN_SRC_DIR}\\\\cmake\\\\nsis_logo.bmp")
set(CPACK_NSIS_MODIFY_PATH "ON")
+ set(CPACK_NSIS_ENABLE_UNINSTALL_BEFORE_INSTALL "ON")
+ set(CPACK_NSIS_EXTRA_INSTALL_COMMANDS
+ "ExecWait '$INSTDIR/tools/msbuild/install.bat'")
+ set(CPACK_NSIS_EXTRA_UNINSTALL_COMMANDS
+ "ExecWait '$INSTDIR/tools/msbuild/uninstall.bat'")
endif()
include(CPack)