summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Rose <jordan_rose@apple.com>2014-02-05 00:02:37 +0000
committerJordan Rose <jordan_rose@apple.com>2014-02-05 00:02:37 +0000
commit1b7969eee250d4e3d12666a909971dd26adcbd77 (patch)
tree2752ac4fc39930bccad3195a1852f34ea2da82a9 /CMakeLists.txt
parent7e369ff2e564495211e9cc3d6224057c804621fe (diff)
downloadllvm-1b7969eee250d4e3d12666a909971dd26adcbd77.tar.gz
llvm-1b7969eee250d4e3d12666a909971dd26adcbd77.tar.bz2
llvm-1b7969eee250d4e3d12666a909971dd26adcbd77.tar.xz
[CMake] Move -stdlib=libc++ handling into its own file.
r200744 moved this into cmake/config-ix.cmake, so that it would happen very early in the build process. However, standalone builds of Clang and other external projects never include this file (which is correct). Now, -stdlib=libc++ and the LLVM_COMPILER_IS_GCC_COMPATIBLE option are both set in a new include file, HandleLLVMStdlib, which is included by both config-ix.cmake and HandleLLVMOptions.cmake. This preserves existing behavior for projects relying on HandleLLVMOptions and still does the right thing for builds of LLVM itself. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@200811 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e7275600bc..122c47d4a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -272,14 +272,6 @@ option (LLVM_BUILD_DOCS "Build the llvm documentation." OFF)
option (LLVM_INCLUDE_DOCS "Generate build targets for llvm documentation." ON)
option (LLVM_ENABLE_DOXYGEN "Use doxygen to generate llvm documentation." OFF)
-if( CMAKE_COMPILER_IS_GNUCXX )
- set(LLVM_COMPILER_IS_GCC_COMPATIBLE ON)
-elseif( MSVC )
- set(LLVM_COMPILER_IS_GCC_COMPATIBLE OFF)
-elseif( "${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang" )
- set(LLVM_COMPILER_IS_GCC_COMPATIBLE ON)
-endif()
-
# All options referred to from HandleLLVMOptions have to be specified
# BEFORE this include, otherwise options will not be correctly set on
# first cmake run